Gazebo | Ignition | Community
Ask Your Question

hydro gazebo undefined symbol after update

asked 2014-01-26 11:08:19 -0500

Andrea gravatar image

updated 2014-01-26 11:41:37 -0500

Hello everybody, I am experiencing another problem with gazebo. I am running a 64 bit Ubuntu 12.04 lts with ros hydro. After performing today's updates I tried to run the simulation I was working to and I got the following loading message

    gzserver: symbol lookup error: /opt/ros/hydro/lib/ undefined  symbol: _ZN3ros7console5printEPNS0_10FilterBaseEPN7log4cxx6LoggerENS0_6levels5LevelEPKciS9_S9_z
Msg Waiting for master.[gazebo-2] process has died [pid 8366, exit code 127, cmd /opt/ros/hydro/lib/gazebo_ros/gzserver /home/mago/Development/Repository/ROS/labrob_hydro_hetcont/src/ugv_gazebo/worlds/ __name:=gazebo __log:=/home/mago/.ros/log/6606f8d8-86ab-11e3-96db-8ca9821c9902/gazebo-2.log].
log file: /home/mago/.ros/log/6606f8d8-86ab-11e3-96db-8ca9821c9902/gazebo-2*.log

I thought was a problem of a plugin and I commented out all the plugins from the sdf file. However the problem is not solved.

I have found the following two questions but they did not solve my issue:

Please help

EDIT: I noticed that the problem occurs only using roslaunch,

edit retag flag offensive close merge delete


What version of ros-gazebo-pkgs and gazebo are you using? Are you only using the ROS repository or you are also using

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2014-01-27 18:50:42 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2014-01-29 04:09:44 -0500

Andrea gravatar image

I write a new answer so other users can find it easily. As said by Jose the problem was the use of a mismatched gazebo version. This is what I did:

1) removed from the software resources the repository

2) udpate and upgraded the system

3) Removed the package gazebo-current that implied the removal of the package ros-hydro-desktop-full

4) installed again the ros-hydro-desktop-full package that installed the correct gazebo version.

Thanks for the help provided!

Bye Andrea

edit flag offensive delete link more



Remember that this only a workaround, we will update the issue as soon as it is properly fixed.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2014-01-30 19:11:34 -0500 )edit

It is now fixed, you should not need to remove OSRF repository.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2014-02-06 16:16:53 -0500 )edit

I think I will stick with the current working version. Thank you anyway you have been really helpful!

Andrea gravatar imageAndrea ( 2014-02-06 16:22:05 -0500 )edit

Is there an actual fix to this? Or should it work with an upgrade. I have recently upgraded but now find that this error is interferring with my previously working roslaunch launches. Are there any further steps to be undertaken?

PMilani gravatar imagePMilani ( 2014-04-05 21:24:09 -0500 )edit

Depends on the version of gazebo you are using. Is it the one from the osrf repositories? Could you give some more details?

Andrea gravatar imageAndrea ( 2014-04-06 04:20:19 -0500 )edit

Its Gazebo 2.2.2, I thought it was installed when I installed hydro as 1.9.+. 'apt-cache policy', lists the osrf i386 and amd64 repositories. An apt-get upgrade bought it up to Gazebo 2.2.2.

PMilani gravatar imagePMilani ( 2014-04-06 04:41:25 -0500 )edit

Hi actually if you install Hydro from ROS repositories the last version is gazebo 1.9.5. You probably installed the version you have from the osrf repositories. Delete the osrf repo and install hydro + gazebo from ros repo. Follow the passages I wrote in the answer ;)

Andrea gravatar imageAndrea ( 2014-04-06 04:45:10 -0500 )edit

Thanks Andrea that worked, I'd not followed your directions as Jose indicated I shouldn't need to. But in fact it seems that roslaunch works with version 1.9.5 and not with 2.2.2

PMilani gravatar imagePMilani ( 2014-04-06 05:20:42 -0500 )edit

Happy to hear that you solved the problem :)

Andrea gravatar imageAndrea ( 2014-04-06 05:22:09 -0500 )edit

answered 2014-01-30 16:25:25 -0500

Jose Luis Rivero gravatar image

Looks like the same problem described in the issue tracker. Let's follow the works to fix it there.

edit flag offensive delete link more

answered 2014-01-27 05:57:49 -0500

Andrea gravatar image

Here is the log file of roslaunch

It may be useful

[roslaunch][INFO] 2014-01-27 12:44:10,671: Checking log directory for disk usage. This may take awhile. Press Ctrl-C to interrupt

[roslaunch][INFO] 2014-01-27 12:44:16,141: master.isrunning[http://localhost:11311] [roslaunch][INFO] 2014-01-27 12:44:16,243: master.isrunning[http://localhost:11311] [roslaunch][INFO] 2014-01-27 12:44:16,343: master.isrunning[http://localhost:11311] [roslaunch][INFO] 2014-01-27 12:44:16,347: master.isrunning[http://localhost:11311] [roslaunch][INFO] 2014-01-27 12:44:16,349: ROSMASTERURI=http://localhost:11311 [roslaunch][INFO] 2014-01-27 12:44:16,351: setting /runid to 562a6bf0-8748-11e3-b40d-8ca9821c9902 [roslaunch][INFO] 2014-01-27 12:44:16,354: setting /roslaunch/uris/hostmagoxpsl501x_54926' to http://mago-XPS-L501X:54926/ [roslaunch][INFO] 2014-01-27 12:44:16,358: ... preparing to launch node of type [rosout/rosout] [roslaunch][INFO] 2014-01-27 12:44:16,450: ... successfully launched [rosout-1] [roslaunch][INFO] 2014-01-27 12:44:16,450: loadparameters starting ... [roslaunch][INFO] 2014-01-27 12:44:16,455: ... loadparameters complete [roslaunch][INFO] 2014-01-27 12:44:16,455: launchnodes: launching local nodes ... [roslaunch][INFO] 2014-01-27 12:44:16,455: ... preparing to launch node of type [gazeboros/gzserver] [roslaunch][INFO] 2014-01-27 12:44:16,455: createnodeprocess: package[gazeboros] type[gzserver] machine[Machine(name[] envloader[None] address[localhost] sshport[22] user[None] assignable[True] timeout[10.0])] masteruri[http://localhost:11311] [roslaunch][INFO] 2014-01-27 12:44:16,512: ... created process [gazebo-2] [roslaunch.pmon][INFO] 2014-01-27 12:44:16,512: ProcessMonitor.register[gazebo-2] [roslaunch.pmon][INFO] 2014-01-27 12:44:16,512: ProcessMonitor.register[gazebo-2] complete [roslaunch][INFO] 2014-01-27 12:44:16,512: ... registered process [gazebo-2] [roslaunch][INFO] 2014-01-27 12:44:16,528: ... successfully launched [gazebo-2] [roslaunch][INFO] 2014-01-27 12:44:16,528: ... preparing to launch node of type [gazeboros/gzclient] [roslaunch][INFO] 2014-01-27 12:44:16,594: ... created process [gazebogui-3] [roslaunch.pmon][INFO] 2014-01-27 12:44:16,594: ProcessMonitor.register[gazebogui-3] [roslaunch.pmon][INFO] 2014-01-27 12:44:16,594: ProcessMonitor.register[gazebogui-3] complete [roslaunch][INFO] 2014-01-27 12:44:16,594: ... registered process [gazebogui-3] [roslaunch][INFO] 2014-01-27 12:44:16,639: ... preparing to launch node of type [gazeboros/spawnmodel] [roslaunch.pmon][INFO] 2014-01-27 12:44:16,711: registrations completed <processmonitor(processmonitor-1, started="" daemon="" 140345190778624)&gt;="" [roslaunch.parent][info]="" 2014-01-27="" 12:44:16,711:="" ...="" roslaunch="" parent="" running,="" waiting="" for="" process="" exit="" [roslaunch][info]="" 2014-01-27="" 12:44:16,712:="" spin="" [="" roslaunch][error]="" 2014-01-27="" 12:44:20,824:="" [gazebo-2]="" process="" has="" died="" [pid="" 2899,="" exit="" code="" 127,="" cmd="" opt="" ros="" hydro="" lib="" gazebo<em="">ros/gzserver /home/mago/Development/Repository/ROS/labrobhydrohetcont/src/ugvgazebo/worlds/ _name:=gazebo _log:=/home/mago/.ros/log/562a6bf0-8748-11e3-b40d-8ca9821c9902/gazebo-2.log]. log file: /home/mago/.ros/log/562a6bf0-8748-11e3-b40d-8ca9821c9902/gazebo-2*.log [roslaunch.pmon][INFO] 2014-01-27 12:44:20,824: ProcessMonitor.unregister[gazebo-2] starting [roslaunch.pmon][INFO] 2014-01-27 12:44:20,824: ProcessMonitor.unregister[gazebo-2] complete [roslaunch.pmon][INFO] 2014-01-27 12:44:46 ... (more)

edit flag offensive delete link more



What is exactly the roslaunch command are you running? Is it from a catkin workspace?

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2014-01-27 18:52:31 -0500 )edit

To answer to all of your questions:

1) I am using Ros Hydro and Gazebo 2.2 2) ros-gazebo-pkgs is at version 2.4.1 3) the repositories I am using are 4) the command I am using is roslaunch ugv_gazebo ugv.launch

Thank you!

Andrea gravatar imageAndrea ( 2014-01-28 09:20:41 -0500 )edit

Sounds to me like there is an ABI change in one of the dependencies of ros-gazebo-pkgs which broke the package. I recommend to give a look at ROS and Gazebo installation and as workarounds: not to use OSRF repository (unless you have a good reason) or use your current setup and configure a catkin workspace which include ros-gazebo-pkgs and any other required ugv package.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2014-01-28 17:15:04 -0500 )edit
Login/Signup to Answer

Question Tools


Asked: 2014-01-26 11:08:19 -0500

Seen: 2,068 times

Last updated: Jan 30 '14