Gazebo | Ignition | Community
Ask Your Question

Installation problems

asked 2014-02-06 23:55:18 -0500

Robert gravatar image

updated 2014-02-10 09:50:42 -0500

I am new to gazebo and I just installed gazebo1.9 using pre-compiled binaries and following the instructions from And when I tried to check my installation with gzserver (ok) and gzclient (error) I got the following error message connection:

Msg Waiting for master.............................. Error [] Failed to connect to master in 30 seconds.

I uninstalled once to change the version but still have the same error. I followed very carefully the instructions. Please help I don't know what to do. Thanks a lot in advance

edit retag flag offensive close merge delete


The message says it is waiting for the server to start

is the server running when you start the client? have you tried running gazebo instead of gzclient and gzserver?

evilBiber gravatar imageevilBiber ( 2014-02-07 09:10:47 -0500 )edit

Thanks for your reply. Yes, i also tried running gazebo instead of gzclient and gzserver and I got the same results with differente cc:# . I just found a paper that stated the error maybe due to GPU settings. Here is the link I will check that and I hope this the problem

Robert gravatar imageRobert ( 2014-02-07 10:34:37 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-02-07 08:32:33 -0500

mfran89 gravatar image

Hey what your problem maybe is that you need to update your rosconsole pkg on your ROS Hydro side to the version below.

ros-hydro-rosconsole (1.9.54 version)

Here is a link to the issue I was having recently having hopefully it helps you out.

edit flag offensive delete link more


Thanks for your reply. I don't have ROS install in my laptop since I am new to Gazebo and I just try to learn some of Gazebo before jumping into ROS/Gazebo. I just found a paper that stated this problem might be due the GUP that is not supported completely by ubuntu and the GUP need some settings to make work with Gazebo. Here is the link

Robert gravatar imageRobert ( 2014-02-07 10:29:41 -0500 )edit

answered 2014-02-10 09:47:02 -0500

Robert gravatar image

updated 2014-02-10 09:49:20 -0500

I think my problem was that GUP car was too dated for gazebo1.9 (AMD Radeon hd6620g). I installed the same version of Gazebo on another laptop with dual GUP car (Nvidia gtx 675m and Intel hd 4000) and gazebo is running ok. Thanks for your replies

edit flag offensive delete link more
Login/Signup to Answer

Question Tools


Asked: 2014-02-06 23:55:18 -0500

Seen: 289 times

Last updated: Feb 10 '14