Gazebo | Ignition | Community
Ask Your Question

Error with gzserver: floating point exception

asked 2014-02-19 22:02:47 -0500

Frenetique gravatar image

Hi everyone,

I'm completely new to the gazebo world that I need to use for a robot project. I am running on Ubuntu 13.10 (Saucy) and I'm trying to install the gazebo 2.0 following these instructions:

Everything works fine until the I have to use the command:


Indeed what I get in the terminal is as follow (the last few lines):

Msg Waiting for master Msg Connected to gazebo master @ Msg Publicized address: Floating point exception (core dumped)

I saw another thread about this issue with no answer and it is quite old now.

I also tried to install an older version of gazebo (just to see), and when I use the command line :

sudo apt-get install gazebo

Which should install the 1.9 version, I get the following response.

Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: gazebo : Depends: sdformat (>= 1.4.7~) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

I'm completely stuck right now and don't know what to do. I don't know if it is related to the current distrib of Ubuntu that has some trouble with gazebo of if it's something else. If you have any suggestions or even a solution I would appreciate it.

Thanks in advance.

Best regards.

edit retag flag offensive close merge delete


Can you post a backtrace from gzserver?

nkoenig gravatar imagenkoenig ( 2014-02-20 11:35:10 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-02-21 20:50:12 -0500

Frenetique gravatar image

I solved my problem as follow.

I now use Ubuntu 12.04.4 LTS. The non proprety drivers (the ones provided as open source with Ubuntu) were not able to run my CG, indeed it was not recognized and it was using the integrated graphic accelerator chipset of the motherboard I guess. So I installed the ATI drivers (non beta) and it worked.

The problem with Ubuntu 13.10 is that the drivers provided are not very effective yet (apparently).

So this issue was in this case effectively related to the AMD/ATI driver and still is I guess. Thanks for the people on the link provided by nkoenig, it took me on the good track.

edit flag offensive delete link more

answered 2014-02-20 11:39:23 -0500

nkoenig gravatar image

This question is being tracked on this issue

edit flag offensive delete link more

Question Tools


Asked: 2014-02-19 22:02:47 -0500

Seen: 655 times

Last updated: Feb 21 '14