Error when installing from source on ubuntu 12.04

asked 2014-03-09 11:54:00 -0500

AndreiHaidu gravatar image

updated 2014-03-10 08:26:15 -0500

Hi,

I am getting a building error when installing from source under ubuntu 12.04.

The error:

gazebo-2.2.1/interfaces/player/player.h:22:38: fatal error: libplayercore/playercore.h: No such file or directory

the header file is located here:

/usr/include/player-3.0/libplayercore/playercore.h

Same error appears for older versions as well, such as 1.8.0.

The command sudo apt-get remove libplayer* did not fixed it for me, as in the following answer.

Also, under ubuntu 12.04 sudo apt-get install libogre-1.8-dev does not work, maybe the install tutorials should be updated?

=============UPDATE===================

here is the issue on bitbucket

edit retag flag offensive close merge delete

Comments

have you tried using deb for installation. Deb package for version 2.2.1 is available as well !

nitin gravatar imagenitin ( 2014-03-10 00:34:34 -0500 )edit

thanks for the answer, the deb works just fine, I just needed the source installation ;)

AndreiHaidu gravatar imageAndreiHaidu ( 2014-03-10 08:24:29 -0500 )edit