Hokuyo not pubishing to ROS [closed]

asked 2014-03-24 05:09:26 -0500

Eisenhorn gravatar image


I would like to publish laser scans, that are performed by e.g the Hokuyo Model in Gazebo to ROS. I have tried this with Fuerte and Hydro without success.

I used this materials: Gazebo 1.9 ROS Hydro Ubuntu 12.04

I then started Gazebo with this command

roslaunch gazebo_ros empty_world.launch

This then gives me these topics in ROS

rostopic list

In Gazebo I added the Hokuyo model which is already included. I can see the scanarea indicated in blue. I can'T see any new topic in ROS. I can see in the model.sdf that it uses the libRayPlugin.so Plugin. Furthermore I noticed that a topic tag is missing inside the sensor tag. I added one. Still no publishing.Thas how the sensor section model.sdf of the Hokuyo looks like

  <sensor name="laser" type="ray">
        <pose>0.01 0 0.0175 0 -0 0</pose>

        <plugin name="laser" filename="libRayPlugin.so" />

I tried different topics such as /laserscan, laserscan. Am I missing something?

BR & and thanks for any help

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by nkoenig
close date 2014-03-25 13:20:30.626378


Ok I solved that problem. I cheanged the plugin to this <plugin name="laser" filename="libgazeboroslaser.so"> <topicName>/hokuyo_laser</topicName> <frameName>map</frameName> </plugin>

Eisenhorn gravatar imageEisenhorn ( 2014-03-24 08:51:34 -0500 )edit