Home | Tutorials | Wiki | Issues
Ask Your Question
0

Installing 1.9gazebo from source in local directory, error

asked 2014-04-22 18:51:10 -0500

Robert gravatar image

updated 2014-04-23 12:34:06 -0500

scpeters gravatar image

Hi Hi Everyone, I have tried to install 1.9Gazebo from source using local directory. Everything went well until the last step, "Setup enviroment variables" I follow the instructions below:


echo "export LD_LIBRARY_PATH=<install_path>/local/lib:$LD_LIBRARY_PATH" >> ~/.bashrc
echo "export PATH=<install_path>/local/bin:$PATH" >> ~/.bashrc
echo "export PKG_CONFIG_PATH=<install_path>/local/lib/pkgconfig:$PKG_CONFIG_PATH" >> ~/.bashrc
source ~/.bashrc

And I got the following error:


bash: install_path: No such file or directory

Then when I run Gazebo ../path$ gazebo I got the error "command not found" I am new on linux so I couldn't figure out yet how to fix this problem This is the second time that installs Gazebo from source. The first time I successfully installed it using the default path (/usr/local) but I failed installing gazeborospack. This why I am reinstalling gazebo for the second time using local directory and see if I could successfully install gazeborospacks . Are there any differences-advantages of installing gazebo from source using the default path or local directory?? Thanks you for your help in this matter

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-04-23 17:45:43 -0500

Jose Luis Rivero gravatar image

Well the

<install_path>

label was supposed to be replaced by your filesystem install path, typically by /usr.

edit flag offensive delete link more

Comments

Thanks Jose!

Robert gravatar imageRobert ( 2014-04-23 19:22:17 -0500 )edit

Jose, i made the changes and I realized that "make" creates for PKGCONFIGPATH the path ".../lib/i386-linux-gnu/pkgconfig" instead of ".../lib/pkgconfig" which appears on the instructions. I am wondering if it will cause a problem or I might made a mistake somewhere during the process. Thanks a lot in advance for any input

Robert gravatar imageRobert ( 2014-04-23 19:31:44 -0500 )edit

That is a valid multiarch path, don't need to worry, should work just fine. Another point, could please mark the answer as valid by clicking the tick button? It helps me to know what answers are still waiting.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2014-04-25 12:32:26 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-04-22 18:51:10 -0500

Seen: 214 times

Last updated: Apr 23 '14