Gazebo | Ignition | Community
Ask Your Question

DRCSIM 1.3.1 / Gazebo 1.3 does not start

asked 2013-01-08 11:27:17 -0500

Felipe Bacim gravatar image

updated 2013-01-09 12:20:02 -0500

Hey guys,

I've been having problems starting drcsim/gazebo ever since I updated a few ros-fuerte packages back in December (around the 17th). Back then, I was using gazebo 1.3 and the drcsim 1.2, and now with drcsim 1.3.1 I still get the same error:

Error [] Unable to get topic namespaces in [50] tries.
Error [] No namespace found

I've searched through gazebo answers, bitbucket and so on (look at the end for links), but while most of the problems seem related to graphics drivers (raising exceptions with X server), mine does not raise any exceptions or gives any clue about what the error might be (look at the end for a link to the complete output). It does seem to be related to ogre or qt, since it does not even initialize the window.

I've tried reinstalling drivers, removing all ros-fuerte packages and installing them again, removing gazebo and drcsim and installing them again, and the same thing with ogre related packages. I've also tried doing a fresh install of ubuntu 12.04 and everything on this machine (I thought maybe the kernel had been updated and somehow it broke some packages) and simply following these steps:

# install ubuntu 12.04, without any updates
sudo apt-get install nvidia-current
# add ros/gazebo servers to sources
sudo apt-get install drcsim

But it did not work as well, with the same error and everything. The ros server still runs in the background, it's just that gazebo shows that message and then quits without ever bringing up its window.

Anyway, I'm hoping someone has a clue about what is happening. FYI, my graphics card is a GeForce 9800 GT, and glxinfo shows no problems I think (direct rendering: yes).

Here are the links to other related posts:

Here is the link to gazebo output:

edit retag flag offensive close merge delete


Forgot to mention that rviz works fine, so if it is a problem with ogre/qt, it's in the combination of ros-fuerte, gazebo and those libraries.

Felipe Bacim gravatar imageFelipe Bacim ( 2013-01-09 12:19:34 -0500 )edit

can you try: source /usr/share/drcsim/ gazebo and see if gazebo itself starts up?

hsu gravatar imagehsu ( 2013-01-09 23:06:47 -0500 )edit

Yes, here it is:

Same error without the exceptions and warnings.

Here is the logfile that is generated when I run the drcsim:

It might be useful since it shows all the env variables and so on.

Felipe Bacim gravatar imageFelipe Bacim ( 2013-01-09 23:16:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-01-09 15:29:08 -0500

nkoenig gravatar image

The Gazebo output you have posted through pastebin indicates some serious issues. It looks like you don't have a properly configured system. You should not have any Exception errors when ROS starts. The same is true for all the warning messages.

I check to make sure you have ROS and Gazebo properly installed, and you've sourced the correct files.

edit flag offensive delete link more


The exceptions seem to be a python bug, and according to it should not be an issue. I followed all the steps in and I'm sourcing /usr/share/drcsim/ as specified there.

Felipe Bacim gravatar imageFelipe Bacim ( 2013-01-09 22:23:06 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2013-01-08 11:27:17 -0500

Seen: 422 times

Last updated: Jan 10 '13