Gazebo | Ignition | Community
Ask Your Question
0

Why Gazebo 1.3 so slow?

asked 2013-01-09 11:18:19 -0500

r0nald gravatar image

updated 2013-01-09 11:18:30 -0500

I have tried the Gazebo which came together with ROS Fuerte(I guess version 1.0) and I now installed Gazebo 1.3, which has a different UI and is terribly slow.

Is it expected that the newer Gazebo takes so much more resources (uses full virtual core of my i7 processor)? Rotating, zooming and panning the world is extreamly slow.

edit retag flag offensive close merge delete

Comments

Is this a problem with the UI being sluggish or physics update? What does the "Real Time Factor:" window near the bottom say?

hsu gravatar imagehsu ( 2013-01-09 11:43:04 -0500 )edit

The standard UI elements outside the world view are ok. But changing the view in the world is very slow, even when the simulation paused. "Real Time Factor" changes between 0.99 and 1.0. I inserted the robot model from Gazebo tutorial, made it move and it isn't moving smoothly.

r0nald gravatar imager0nald ( 2013-01-09 12:08:09 -0500 )edit
1

sounds like your gui might be using software acceleration. Can you post the outputs of glxinfo? and if one of the lines says: "client glx vendor string: Mesa Project and SGI", then it's not doing hardware acceleration.

hsu gravatar imagehsu ( 2013-01-09 12:55:07 -0500 )edit

Output of the flxinfo : http://nopaste.info/34e477319d.html

Yes, it does say "client glx vendor string: Mesa Project and SGI"

r0nald gravatar imager0nald ( 2013-01-09 16:21:43 -0500 )edit

that means you're not using your gpu's hardware acceleration, mesa software acceleration is expected to be cpu intensive and slow (I've seen upwards of 6 cores on my i7). To take advantage of your gpu, make sure you have the right driver installed.

hsu gravatar imagehsu ( 2013-01-09 17:01:16 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-01-11 19:35:39 -0500

hsu gravatar image

Gazebo client GUI performance suffers with software rendering when glx supported GPU hardware & driver is absent. To fix this, enable hardware acceleration by finding and installing a working GPU driver.

edit flag offensive delete link more

Comments

There seems to be a common bug in Ubuntu which affects the Intel graphics of my Thinkpad X220 ( https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/999493 ). Is there a way to turn off some 3D rendering features of Gazebo to trade detailed graphics for better performance?

r0nald gravatar imager0nald ( 2013-01-12 08:21:33 -0500 )edit

I don't know exactly what package needed to be updated, but I got the performance improved now. The string "client glx vendor string: Mesa Project and SGI" is still there, but what changed was :

"OpenGL vendor string: Tungsten Graphics, Inc" to "OpenGL vendor string: Intel Open Source Technolog

r0nald gravatar imager0nald ( 2013-01-12 16:36:10 -0500 )edit

try and see if you can tell what package installed your system's working libGL.so

hsu gravatar imagehsu ( 2013-01-12 20:50:36 -0500 )edit

lrwxrwxrwx 1 root root 13 Jan 10 19:21 /usr/lib/i386-linux-gnu/libGL.so -> mesa/libGL.so

r0nald gravatar imager0nald ( 2013-01-13 05:30:09 -0500 )edit

Although the Gazebo UI became more usable, heightmap textures are still black, similarly to the bug described here: https://bitbucket.org/osrf/gazebo/issue/70/drc-terrain-is-completely-black-on-intel If I zoom very far from the terrain, then it becomes visible.

r0nald gravatar imager0nald ( 2013-01-14 06:04:46 -0500 )edit
0

answered 2013-01-13 10:55:31 -0500

nkoenig gravatar image
edit flag offensive delete link more
0

answered 2013-01-13 10:55:52 -0500

nkoenig gravatar image
edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2013-01-09 11:18:19 -0500

Seen: 2,044 times

Last updated: Jan 13 '13