Gazebo | Ignition | Community
Ask Your Question
0

installing gazebo 3.0 from source... "cannot open shared object" error

asked 2014-05-28 22:57:08 -0500

idhamb gravatar image

updated 2014-05-28 23:02:46 -0500

Hello,

I've made numerous attempts to get around this issue... read all similar past queries, but I'm completely new to linux so I have absolutely no idea how to interpret some of the answers

so, in the instructions (http://gazebosim.org/wiki/3.0/install), step 10, you're told to execute "gazebo", I end up with:

gazebo: error while loading shared libraries: libgazebo_common.so.3: cannot open shared object file: No such file or directory

during cmake, the installation path was shown as: /home/derek/gazebo_source/gazebo/build

it said to take note of this, so I did. I then came upon instructions later about installation to local directories and such,

echo "export LD_LIBRARY_PATH=<install_path>/local/lib:$LD_LIBRARY_PATH" >> ~/.bashrc
echo "export PATH=<install_path>/local/bin:$PATH" >> ~/.bashrc
echo "export PKG_CONFIG_PATH=<install_path>/local/lib/pkgconfig:$PKG_CONFIG_PATH" >> ~/.bashrc
source ~/.bashrc

I tried every variation of replacing the <install_path> with the one designated by the cmake output, but to no avail... then, at the end of the instructions, you get this:

echo '/usr/local/lib' | sudo tee /etc/ld.so.conf.d/gazebo.conf 
sudo ldconfig

again, I don't really know what /usr/local/lib (i understand that this is where user files go, but as far as relating this to the GUI directory of /home/USER/gazebo etc) means, I tried every combination of prefixes that I could think of

Any assistance would be greatly appreciated, thank you

edit retag flag offensive close merge delete

Comments

If you have run cmake with the proper CMAKE_INSTALL_PREFIX pointing to /usr the libraries should end up with the libraries on /usr/lib/... and don't need to use ldconfig at all.

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2014-05-29 08:01:25 -0500 )edit

this will be a last resort if i cant find a solution for the current installation, but will definitely give it a go tonight if i cant resolve this.

idhamb gravatar imageidhamb ( 2014-05-29 08:16:04 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-29 06:03:42 -0500

AndreiHaidu gravatar image

Hi,

when running the

echo '/usr/local/lib' | sudo tee /etc/ld.so.conf.d/gazebo.conf 
sudo ldconfig

command make sure you change '/usr/local/lib' to where your gazebo libraries are, do a $ locate libgazebo in the terminal to find out where they are.

Cheers, Andrei

edit flag offensive delete link more

Comments

i typed in "locate libgazebo" into a terminal, doesn't return anything... i tried a variety of 'search' and 'find' commands i found on the web to ID the correct path, nothing works :/

idhamb gravatar imageidhamb ( 2014-05-29 08:17:38 -0500 )edit

tried $locate libgazebo, said "libgazebo not found", tried $locate libgazebo_common.so.3, same thing :/

idhamb gravatar imageidhamb ( 2014-05-29 08:19:48 -0500 )edit

find /usr -name libgazebo*

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2014-05-29 08:42:47 -0500 )edit

success! thank you Jose, thank you Andrei!

idhamb gravatar imageidhamb ( 2014-05-29 13:19:55 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-05-28 22:57:08 -0500

Seen: 2,593 times

Last updated: May 29 '14