Gazebo | Ignition | Community
Ask Your Question

gzserver would not launch

asked 2014-06-19 10:42:01 -0500

K. Zeng gravatar image

updated 2014-06-19 10:48:48 -0500

Hi everyone. I'm currently trying to get Gazebo working on a different computer from the one I previously mentioned. However, Gazebo would not launch at all. I get the following message when I try to run the commands "gazebo" or "gzserver":
Xlib: extension "NV-GLX" missing on display ":0.0".
Xlib: extension "NV-GLX" missing on display ":0.0".
X Error of failed request: GLXUnsupportedPrivateRequest
    Major opcode of failed request: 154 (GLX)
    Minor opcode of failed request: 16 (X_GLXVendorPrivate)
    Serial number of failed request: 24
    Current serial number in output stream: 25

I tried to install NVIDIA drivers to see if it will gzserver to run, but if I start up my PC after installing nvidia-current and nvidia-driver, I get a black screen after I log in. The only thing accessible is the terminal. I've had to reinstall my OS several times because of the black screen issue.

I'm using Ubuntu 13.10, ROS Indigo, and Gazebo 2.2.2 with the necessary dependencies and upgrades. If it helps, my PC specs are as follows:
Memory: 1.9 GB
Processor: Intel Core 2 Duo CPU E8200 @ 2.66GHz x 2
Graphics: Intel Q35

I did try to use Trusty, but gzclient crashes and gives me a generic "Segmentation fault (core dumped)" message and no other error types. I can upload the backtrace for that one if you guys want.

I've searched online already, and all I got is people complaining about not being able to play their video games on Ubuntu. The solutions suggested in those forums all involve using the Windows emulator Wine. Is there a solution to the Xlib problem that's specific to Gazebo? Any help would be greatly appreciated.

edit retag flag offensive close merge delete


Try glxgears - "sudo apt-get install mesa-utils" and then "glxgears". If you can't get that to run, you've got video driver problems that probably should go in some other forum.

jonbinney gravatar imagejonbinney ( 2014-06-19 16:40:14 -0500 )edit

and look into your ~/.gazebo/ogre.log to see if this is caused by your video driver... but gzserver should not need 3d drivers...

evilBiber gravatar imageevilBiber ( 2014-06-22 05:29:35 -0500 )edit

I tried "sudo apt-get install mesa-utils" and then "glxgears". The computer still produced a black screen upon login. I haven't checked my ~/.gazebo/ogre.log yet, but I have a couple of alternate computers that I can work with. Thanks for the help so far, you can lock it if you want since it's not that high of a priority for me at the moment.

K. Zeng gravatar imageK. Zeng ( 2014-06-30 15:30:10 -0500 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-07-03 08:42:28 -0500

nkoenig gravatar image

Good answers are in the comments.

Some notes:

  1. Search other forums/google for opengl drivers for your graphics card. Since you have an Intel graphics chipset, nvidia drivers will not work.

  2. Install mesa-utils, and run glxinfo | grep "direct rendering". The output should be "direct redering: yes"

  3. gzserver should run without the need for graphics support. The caveat being you can't use a robot with a camera sensor, which requires opengl for off-screen rendering.

edit flag offensive delete link more

Question Tools


Asked: 2014-06-19 10:42:01 -0500

Seen: 3,195 times

Last updated: Jul 03 '14