Gazebo | Ignition | Community
Ask Your Question
0

Stopping a Robot Through Friction?

asked 2014-07-14 14:17:42 -0500

K. Zeng gravatar image

updated 2014-07-14 14:21:08 -0500

So right now I'm trying to set up the friction of the ground plane (relevant parameters are mu and mu2) so that a 4-wheeled robot (SDF format, no friction mu values set for any links) will come to a stop after rolling down a slope. The software I'm using is Gazebo 2.22 along with ROS Indigo. I'm using the default version of the ground plane as below, with different values of mu and mu2:

<?xml version="1.0" ?>
<sdf version="1.5">
  <model name="ground_plane">
    <static>true</static>
    <link name="link">
      <collision name="collision">
        <geometry>
          <plane>
            <normal>0 0 1</normal>
            <size>100 100</size>
          </plane>
        </geometry>
        <surface>
          <friction>
            <ode>
              <mu>100</mu>
              <mu2>50</mu2>
            </ode>
          </friction>
        </surface>
      </collision>
      <visual name="visual">
        <cast_shadows>false</cast_shadows>
        <geometry>
          <plane>
            <normal>0 0 1</normal>
            <size>100 100</size>
          </plane>
        </geometry>
        <material>
          <script>
            <uri>file://media/materials/scripts/gazebo.material</uri>
            <name>Gazebo/Grey</name>
          </script>
        </material>
      </visual>
    </link>
  </model>
</sdf>

Now, there were no problems with the robot actually going down the hill, but I did notice that even with the ground plane's mu and mu2 set to maximum (100, 100), the model went at a (slow) constant velocity with no signs of stopping after coming down the hill. I'm trying to avoid setting the mu and mu2 values for the model itself, but are there other parameters that I need to adjust so the robot can actually come to a stop after rolling down the hill? Any help would be greatly appreciated.

edit retag flag offensive close merge delete

Comments

I have the same problem.My robot alway slides on the ground,even if I set friction up to 1000.......

Zheng yo chen gravatar imageZheng yo chen ( 2014-07-17 04:14:38 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2020-12-18 13:13:28 -0500

nkoenig gravatar image

You will need the wheel slip plugin enabled to avoid slipping down the hill when the robot is stationary.

The plugin: https://github.com/osrf/gazebo/blob/g...

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-07-14 14:17:42 -0500

Seen: 669 times

Last updated: Dec 18 '20