Gazebo | Ignition | Community
Ask Your Question

Model SDF parsing error [closed]

asked 2013-01-10 17:47:41 -0500

klowrey gravatar image

updated 2013-01-11 18:36:31 -0500

After working with gazebo/drcsim all day yesterday with only the occasional crash/freeze, I started up my projects today to find that the atlas model.urdf will not load.

If I were to run:

roslaunch atlas_utils atlas.launch

I get the following Errors:

Warning [] SDF has no <sdf> element in file[/usr/share/drcsim-1.3/models/atlas/model.urdf]
Error [] Unable to read file[/usr/share/drcsim-1.3/models/atlas/model.urdf]
Error [] Error reading element <world>
Error [] Unable to read element <sdf>
Error [] Unable to read sdf file[]

And gazebo/drcsim exits cleanly. This similarly happens if the Atlas model is loaded from the Gazebo gui (with roscore running as well).

The solutions I've tried:

  • Complete uninstall of ROS/Gazebo/DRCSIM and reinstallation, including wiping the keys/repositories of these packages.
  • Regenerating the model.urdf under a different name using the rosrun xacro command to encounter the same error
  • Renaming world files, model files, running gzsdf to update SDF files

Any assistance to get gazebo up and running would be very appreciated.

EDIT: env | grep GAZEBO:


env | grep ROS:

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by nkoenig
close date 2013-08-02 14:50:32.968886


Did you do a

sudo apt-get update

first before re-installing the components? Also, can you see the file at


? Is it the same as the file below?

hsu gravatar imagehsu ( 2013-01-10 21:00:08 -0500 )edit

yes, after uninstalling, I reloaded the URLs, did an apt-get update, and reinstalled. The model.urdf at the url is idential to the one under /drcsim-1.3/model, and even urdf files newly generated through xacro have the same parsing error. Is there more debug info I can provide?

klowrey gravatar imageklowrey ( 2013-01-11 12:29:44 -0500 )edit

Try: gzsdf print /usr/share/drcsim-1.3/models/atlas/model.urdf. This command should not fail, and it should produce a lot of SDF output.

nkoenig gravatar imagenkoenig ( 2013-01-13 11:30:06 -0500 )edit

Warning [] SDF has no <sdf> element in file[/usr/share/drcsim-1.3/models/atlas/model.urdf] Error: SDF parsing the xml failed

hum... that's interesting. Is the urdf parsing binary your code links to possibly corrupted? I've purged all of ros as well before re-installing...

klowrey gravatar imageklowrey ( 2013-01-14 12:27:13 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-01-11 16:46:12 -0500

hsu gravatar image


Warning [] SDF has no <sdf> element in file[/usr/share/drcsim-1.3/models/atlas/model.urdf]

is expected, however,

Error [] Unable to read file[/usr/share/drcsim-1.3/models/atlas/model.urdf]

should not be there as the parser should then try and parse the model as urdf next. This seems to suggest that ros-fuerte-urdfdom, ros-fuerte-urdfdom-headers, ros-fuerte-console-bridge are not installed properly, or you are running a version of gazebo compiled locally without urdfdom support.

edit flag offensive delete link more


Your suggestion is appreciated. I've since run apt-get purge on every ros-fuerte-* package as well as gazebo and drcsim, apt-get clean, apt-get autoclean, apt-get update, and then finally apt-get install drcsim to reinstall. The same error persists.

klowrey gravatar imageklowrey ( 2013-01-11 17:17:38 -0500 )edit

Can you post the output of `env() | grep GAZEBO` and `env() | grep ROS`?

nkoenig gravatar imagenkoenig ( 2013-01-11 17:56:54 -0500 )edit

The outputs to env are posted above in the initial post. This is after a vigorous scrubbing of all things ros, gazebo, and drcsim on my workstation. If there's no other idea for a solution, I'll just fall back on re-installing 12.04 to continue work.

klowrey gravatar imageklowrey ( 2013-01-11 18:34:56 -0500 )edit

@klowrey what happened? I am getting the same error. Did you resolve it?

peshala gravatar imagepeshala ( 2013-04-26 06:53:39 -0500 )edit

Question Tools



Asked: 2013-01-10 17:47:41 -0500

Seen: 4,048 times

Last updated: Jan 11 '13