Gazebo | Ignition | Community
Ask Your Question

Problem after installing DRCSim

asked 2014-08-04 19:24:43 -0600

nbanyk gravatar image

I've had ROS and Gazebo working fine (Hydro and Gazebo 1.9 on Ubuntu 12.04). Today I installed DRCsim, and now when I try ROSlaunching (or ROSrun) a gazebo_ros package I get the following error:

[gazebo-2] process has died [pid 10651, exit code 127, cmd /opt/ros/hydro/lib/gazeboros/gzserver worlds/ _name:=gazebo __log:=/home/nbanyk/.ros/log/ebba1d2e-1c34-11e4-9f03-00216a935c82/gazebo-2.log]. log file: /home/nbanyk/.ros/log/ebba1d2e-1c34-11e4-9f03-00216a935c82/gazebo-2*.log

[gazebogui-3] process has died [pid 10656, exit code 127, cmd /opt/ros/hydro/lib/gazeboros/gzclient _name:=gazebogui _log:=/home/nbanyk/.ros/log/ebba1d2e-1c34-11e4-9f03-00216a935c82/gazebogui-3.log]. log file: /home/nbanyk/.ros/log/ebba1d2e-1c34-11e4-9f03-00216a935c82/gazebo_gui-3*.log

Currently in my .bashrc file I have the following (bottom two lines were commented because I was troubleshooting to see if that would help): source /opt/ros/hydro/setup.bash source ~/catkinws/devel/setup.bash export GAZEBOMODELPATH=/home/user/catkinws/src/ export EDITOR='nano -w' export GAZEBORESOURCEPATH=/usr/share/gazebo-1.9:/usr/share/gazebomodels:~/catkinws/src source /usr/share/drcsim/ source /usr/share/gazebo/

The interesting thing is that roslaunching the drcsimgazebo package does work, for example: roslaunch drcsimgazebo atlasdrcvehiclefirehose.launch

I saw other related questions on this forum and have tried killing all gzserver's that are running.

Thanks in advance

edit retag flag offensive close merge delete


also getting this error: gzserver: symbol lookup error: /opt/ros/hydro/lib/ undefined symbol: _ZN3ros7package10getPluginsERKSsS2RSt6vectorISsSaISsEE gzclient: symbol lookup error: /opt/ros/hydro/lib/ undefined symbol: _ZN3ros7package10getPluginsERKSsS2RSt6vectorISsSaISsEE /opt/ros/hydro/lib/gazebo_ros/gazebo: 25: kill: invalid signal number or name: SIGINT

nbanyk gravatar imagenbanyk ( 2014-08-05 12:56:51 -0600 )edit
nbanyk gravatar imagenbanyk ( 2014-08-05 12:58:14 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-08-05 18:32:19 -0600

Jose Luis Rivero gravatar image

It was a problem with ROS ABI, it should be fixed.

The reference for the problem is:

edit flag offensive delete link more


thanks, that fixed it!

nbanyk gravatar imagenbanyk ( 2014-08-06 12:41:16 -0600 )edit
Login/Signup to Answer

Question Tools

1 follower


Asked: 2014-08-04 19:24:43 -0600

Seen: 307 times

Last updated: Aug 05 '14