Gazebo | Ignition | Community
Ask Your Question

installing gazebo on mac os x

asked 2014-08-10 13:43:19 -0500

Imhotep gravatar image

I am in the process of installing Gazebo on an iMac running Mac OS 10.9.4

Following the instructions on the Gazebo web page, I made sure Howebrew was up to date, and installed XQuartz.

When installing osrf/simulation I received a warning message:

 sudo brew tap osrf/simulation
 Cloning into '/usr/local/Library/Taps/osrf/homebrew-simulation'...
 remote: Counting objects: 382, done.
 remote: Total 382 (delta 0), reused 0 (delta 0)
 Receiving objects: 100% (382/382), 60.59 KiB | 0 bytes/s, done.
 Resolving deltas: 100% (231/231), done.
 Checking connectivity... done.
 Warning: Could not tap osrf/simulation/protobuf over Homebrew/homebrew/protobuf

When I attempted to install gazebo4, I get an error message:

 sudo brew install gazebo4
 Error: No available formula for gazebo4

I get the same error message when I use "sudo brew install gazeb04 --HEAD"

I (impetuously) attempted to install using "brew install gazebo", which generated a long series of patch and make messages. No errors or warnings (full output list available if needed). However, no executable "gazebo" appears to have been created.

Also, "sudo brew uninstall gazebo" produces the enigmatic message: "Sorry, try again."

Suggestions? Should I just install gazebo3?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-08-11 14:15:53 -0500

scpeters gravatar image

I just created the gazebo4 formula (see also this issue).

As an aside, it's not recommended to use sudo with homebrew.

edit flag offensive delete link more


Thanks.Homebrew rightly recognizes that running Hombrew with sudo creates a security risk.

However, running "brew install gazebo4" generates directory access permission errors.

Changing the permissions of those folders to allow promiscuous access is a greater security risk.

Any suggestions then on how to install using brew without sudo?

Imhotep gravatar imageImhotep ( 2014-08-11 16:15:53 -0500 )edit

So Homebrew rightly recognizes that running Hombrew with sudo creates a security risk.

Imhotep gravatar imageImhotep ( 2014-08-11 16:15:54 -0500 )edit

When I installed home-brew, it asked for my admin password and set the permissions on /usr/local so that sudo wouldn't be required.

scpeters gravatar imagescpeters ( 2014-08-11 16:30:39 -0500 )edit

I'm having the same error now. Is there a new problem?

z.xing gravatar imagez.xing ( 2014-10-27 20:46:49 -0500 )edit
<@z.xing">p>@z.xing, can you post a new question saying what error you have and which version of osx you are using? Thanks.

scpeters gravatar imagescpeters ( 2014-10-28 11:59:30 -0500 )edit

Question Tools

1 follower


Asked: 2014-08-10 13:43:19 -0500

Seen: 1,675 times

Last updated: Aug 11 '14