Gazebo | Ignition | Community
Ask Your Question
0

Robot That Worked in Gazebo 2 Fails to Launch in Gazebo 4

asked 2014-10-23 14:35:21 -0500

K. Zeng gravatar image

updated 2014-10-24 13:15:57 -0500

Related to this question (http://answers.gazebosim.org/question...). I have a robot that previously worked in Gazebo 2 on a different computer that I've been trying to port over to Gazebo 4. For some reason, every time I try to click on the name of the model under the "Insert" tab, Gazebo just exits without any errors or warnings. It was not like this for some of my simpler models or the models that were provided by default in the Gazebo model database. I've checked over the .sdf and .config files but can't find anything wrong with it. I've attached the .sdf file below just in case anyone is interested.
model.sdf

Here is the code for the .config file:

<?xml version="1.0"?>
<model>
  <name>Mesh Robot</name>
  <version>1.0</version>
  <sdf version="1.5">model.sdf</sdf>
  <author>
    <name>John Doe</name>
    <email>john.doe@example.com</email>
  </author>
  <description>
    Insert description here.
  </description>
</model>

The only changes I made after downloading the files onto the computer with Gazebo 4 was that I changed <sdf> version tags from 1.4 to 1.5. The meshes referenced are saved exactly in the folder I wanted. I honesly have no clue what else to do at this point. Any help would be greatly appreciated, thanks.

UPDATE: When I ran Gazebo in verbose mode, I got the following warning.

[Wrn] [ColladaLoader.cc:1361] Polylist input semantic: 'COLOR' is currentlynot supported
edit retag flag offensive close merge delete

Comments

The error message is in the Collada (*.dae) mesh loader. Perhaps that's where the problem is? The Collada code also changed a bit from 2.2 to 4.0 (search for Collada in the Changelog).

scpeters gravatar imagescpeters ( 2014-10-27 00:12:11 -0500 )edit

I'm not sure what I'm trying to look for, but seems like nothing was done to the Collada loader from version 1.9.6 until 4.0.0. The weird thing is that Blender 2.72 (the latest version) doesn't have a problem importing my model and showing it. Another issue is that the .dae file I'm using is too large to change with gedit. Would it be a good idea for me to downgrade to Gazebo 3 for the time being?

K. Zeng gravatar imageK. Zeng ( 2014-10-27 13:45:31 -0500 )edit

Are you able to post the meshes so we can try to reproduce the problem? If there are multiple meshes, try posting the smallest one.

scpeters gravatar imagescpeters ( 2014-10-28 11:49:33 -0500 )edit

Is there an email account I can send the .rar archive to?

K. Zeng gravatar imageK. Zeng ( 2014-10-28 13:14:25 -0500 )edit

It's easiest if you can provide a mesh publicly. Are there any small meshes that you can provide that reproduce the problem with compromising anything you want to keep secret?

scpeters gravatar imagescpeters ( 2014-10-28 13:18:58 -0500 )edit

I'm not worried about confidential information, actually. The problem is more along the lines of me not being able to upload the .rar archive the meshes are stored in for some reason.

K. Zeng gravatar imageK. Zeng ( 2014-10-28 13:21:18 -0500 )edit

Can you put it in a dropbox public folder and share the link?

scpeters gravatar imagescpeters ( 2014-10-28 13:44:27 -0500 )edit

Any luck so far?

K. Zeng gravatar imageK. Zeng ( 2014-10-29 10:41:25 -0500 )edit

I can confirm that the meshes load in meshlab, but not in gazebo4. I'm going to add this to the gazebo issue tracker.

scpeters gravatar imagescpeters ( 2014-10-29 12:49:07 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-10-29 13:02:32 -0500

scpeters gravatar image

I've posted this as an issue on the gazebo issue tracker.

edit flag offensive delete link more

Comments

Thank you.

K. Zeng gravatar imageK. Zeng ( 2014-10-29 13:05:00 -0500 )edit

I noticed that another user marked the issue as solved with the relevant pull request about an hour ago. How long would it be before the change is rolled out? I just re-installed ros-indigo-gazebo4-ros-pkgs again, and it still had the same issue.

K. Zeng gravatar imageK. Zeng ( 2014-11-11 13:17:18 -0500 )edit

current release gazebo 4.0.2 does not contain this patch, see https://bitbucket.org/osrf/gazebo/src/gazebo_4.0/Changelog.md for details. We'll make a release soon with the latest patches for gazebo 4.0.3.

hsu gravatar imagehsu ( 2014-11-11 13:28:32 -0500 )edit

I know that Player has a SVN version (3.1.0) that's contains the latest patches. Is there an equivalent in Gazebo, or do I have to wait?

K. Zeng gravatar imageK. Zeng ( 2014-11-14 19:02:00 -0500 )edit
Login/Signup to Answer

Question Tools

Stats

Asked: 2014-10-23 14:35:21 -0500

Seen: 716 times

Last updated: Oct 29 '14