Home | Tutorials | Wiki | Issues
Ask Your Question

Invalid <param> tag: Cannot load Husky into gazebo

asked 2015-01-04 19:24:11 -0500

Rahul Sharma gravatar image

Hello, I am currently running the Husky packages on gazebo-4.0. It worked fine till yesterday, but when I run it again using roslaunch it shows following error

 rahul@rahul-pc:~/husky_ws$ roslaunch husky_gazebo husky_empty_world.launch 
... logging to /home/rahul/.ros/log/014e7106-9478-11e4-b211-a4db30d7dfe6/roslaunch-rahul-pc-4352.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last):
  File "/opt/ros/indigo/share/xacro/xacro.py", line 60, in <module>
AttributeError: 'module' object has no attribute 'main'
while processing /home/rahul/sample_ws/src/husky_gazebo/launch/base.urdf.gazebo.launch:
Invalid <param> tag: Cannot load command parameter [robot_description]: command [/opt/ros/indigo/share/xacro/xacro.py        '/home/rahul/sample_ws/src/husky_description/urdf/base.urdf.xacro'          gps_enabled:=true         imu_enabled:=true  front_laser:=true     ] returned with code [1]. 

Param xml is <param command="$(find xacro)/xacro.py        '$(find husky_description)/urdf/base.urdf.xacro'          gps_enabled:=$(arg gps_enabled)         imu_enabled:=$(arg imu_enabled)  front_laser:=$(arg front_laser)     " name="robot_description"/>
The traceback for the exception was written to the log file

I don't know how to solve this problem. A little help would be appreciated. Thank you for your useful time



edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-03-09 12:03:46 -0500

I had a similar issue when trying to update and run the husky simulation in indigo. I believe that the current git repo is still in devel and hence full sync is not available yet. Try cloning the urdf directory at https://github.com/husky/huskysimulator.git under the huskygazebo folder and adding it to the /opt/ros/indigo/share/husky_gazebo folder. Make sure to change file permissions to allow writing.

Hope this helps.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools


Asked: 2015-01-04 19:24:11 -0500

Seen: 3,927 times

Last updated: Mar 09 '15