Gazebo | Ignition | Community
Ask Your Question
1

Need help with installing FRCSIM

asked 2015-01-16 18:47:02 -0500

mkcmobile gravatar image

We are using JAVA for our programming language in the FIRST robotics competition. We have the programming progressing well using our Windows and Mac machines but it seems the only way to run a simulation is on a Linux machine. Following the guides though, we are having some issues installing FRCSIM. We have UBUNTU, Eclipse, JAVA, FRC plugins, and even Gazebo 4 installed. We went through the the manual and a YouTube video on installing it. Everything goes fine until it ends with seemingly two dependency errors on frcsim-gazebo-models and frcsim-gazebo-plugins. I found the debian installer packages on first.wpi.edu/FRC/roborio/release/linux/pool/main/f however they seem to want Gazebo 3 installed instead of Gazebo 4 (the current release) and both packages refuse to install. I posted this on Chief Delphi http://www.chiefdelphi.com/forums/showthread.php?t=132896 and they suggested I post a request for help here. Should we go to Gazebo 3? Is there another source for the dependences? At this point it seems the only way to test is on the robot itself. We really would like to use the simulator.

Any help is appreciated! Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-12-04 13:52:13 -0500

zerobits gravatar image

Do you still need help? Are you using Ubuntu 14.04 directly on a PC or through a virtual machine? It must be done on 14.04 (I've tried with others, no luck).

It sounds like you have Gazebo already install which may conflict with the one you need (If I would gander a guess). Is it possible to try reinstalling a fresh installation of Ubuntu 14.04 on your machine? That would be easier than trying to manually remove Gazebo from your machine (not impossible but just annoying).

I have followed the following steps with Ubuntu 14.04 as of December 1st 2015. http://wpilib.screenstepslive.com/s/4...

edit flag offensive delete link more

Comments

Is ubuntu 14.04 required or can the latest 16.04 be used?

robSteele gravatar imagerobSteele ( 2016-10-11 05:49:55 -0500 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2015-01-16 18:47:02 -0500

Seen: 1,200 times

Last updated: Jan 16 '15