Gazebo | Ignition | Community
Ask Your Question

include problem because of gazebo-config.cmake ?

asked 2015-02-03 09:51:32 -0500

yuyu gravatar image

Hi, We are using gazebo-4.1, ros-indigo and ubuntu 14.04. When I added a plugin and catkin_make, I got this error.

/home/user/getit_robot/src/getit_robot_gazebo/include/getit_robot_gazebo/gazebo_ros_planar_move_delay.h:32:35: fatal error: gazebo/common/common.hh: No such file or directory #include <gazebo common="" common.hh=""> ^ compilation terminated.

The build/CMakeCache.txt file does not include GAZEBOINCLUDEDIRS or other parameters, which should be defined in gazebo-config.cmake. $ locate gazebo-config.cmake /usr/lib/x86_64-linux-gnu/cmake/gazebo/gazebo-config.cmake

I added in CMakeLists.txt:

set(GAZEBOINCLUDEDIRS /usr/include;/usr/include/gazebo-4.1;/usr/include/sdformat-2.2) set(GAZEBOLIBRARYDIRS /usr/lib/x8664-linux-gnu;/usr/lib/x8664-linux-gnu/gazebo-4.1/plugins)

(reference: )

Then it compiled. It seems gazebo-config.cmake is not recognized. Why does it happen? Thanks in advance.

(note) If I add this in CMakeLists.txt: find_package(catkin REQUIRED COMPONENTS gazebo REQUIRED # <- added line gazebo_ros roscpp )

Then I received this error.

CMake Error at /opt/ros/indigo/share/catkin/cmake/catkinConfig.cmake:75 (find_package): Could not find a package configuration file provided by "gazebo" with any of the following names: gazeboConfig.cmake gazebo-config.cmake Add the installation prefix of "gazebo" to CMAKE_PREFIX_PATH or set "gazebo_DIR" to a directory containing one of the above files. If "gazebo" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): getit_robot_gazebo/CMakeLists.txt:7 (find_package)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2015-02-12 07:49:52 -0500

yuyu gravatar image

I avoided the situation by adding CMakeLists.txt

set(GAZEBOINCLUDEDIRS /usr/include;/usr/include/gazebo-4.1;/usr/include/sdformat-2.2) set(GAZEBOLIBRARYDIRS /usr/lib/x8664-linux-gnu;/usr/lib/x8664-linux-gnu/gazebo-4.1/plugins)

scpeters, I don't think I installed libgazebo4-dev.

edit flag offensive delete link more

answered 2015-02-04 18:19:20 -0500

scpeters gravatar image

Have you installed libgazebo4-dev?

edit flag offensive delete link more
Login/Signup to Answer

Question Tools



Asked: 2015-02-03 09:51:32 -0500

Seen: 6,933 times

Last updated: Feb 12 '15