Gazebo | Ignition | Community
Ask Your Question
0

Spawning Robot Problem

asked 2015-02-15 11:56:08 -0500

adam896 gravatar image

Hello, so the problem I'm having is most likely due to my inexperience with the software, hopefully a push in the right direction will get me on my way. I have created my own URDF file for a robot, the robot is close to humanoid in shape. When making the URDF file, I developed it so that the robot would be standing perfectly upright this allowed me to give coordinates in the XZ plane making them much simpler. Now, my problem is that the robot actually rests in a sort-of kneeling position so what I have done is make many of the joints revolute and made the upper and lower very close, basically fixing the joint in another position. This worked fine when creating the file n Rvis. When I bring it into Gazebo it appears as though the robot spawns in the standing upright position as the URDF was created for but then very quickly changes to the position specified by the revolute joints, which appears in turn to give some sort of momentum, throwing the robot around. Are there any simple ways to resolve this?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-02-15 16:40:15 -0500

chapulina gravatar image

One thing you can try is checking all your robot's parameters after loading it into Gazebo to see if everything is coming up as you expected.

Start Gazebo paused so the physics doesn't pull it apart (gazebo -u), right-click your robot and choose View -> Joints to see if they're placed as you want. It might help to also choose View -> Transparent.

Also check joint and inertial parameters on the left panel.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

Stats

Asked: 2015-02-15 11:56:08 -0500

Seen: 256 times

Last updated: Feb 15 '15