Gazebo | Ignition | Community
Ask Your Question

Gazebo 2.2 Can't open /usr/share/gazebo//

asked 2015-04-24 09:01:18 -0500

Haz88 gravatar image

updated 2015-04-24 12:19:39 -0500

nkoenig gravatar image


I installed the gazebo 2.2 packages and while typing the roslaunch turtlebot_gazebo turtlebot_world.launch command I continue to get this comment:

Can't open /usr/share/gazebo//

By the way, I'm using this command in order to set the ROS environment variables: source /opt/ros/indigo/setup.bash.

What should I do in order to get rid of this problem?

edit retag flag offensive close merge delete


What is your linux distribution? Are you using the ROS repo? or are you using the repo together with the ROS one?

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2015-04-24 16:46:45 -0500 )edit

Hi, My linux distribution is Ubuntu 14.04(Trusty). I'm using the repo that is mentioned in the Indigo installation tutorial at the Ros website ( , hope that answers your second question.

Haz88 gravatar imageHaz88 ( 2015-04-25 16:17:10 -0500 )edit

I've verified that the gazebo2 package is installing the Could you tell me the result of dpkg -l | grep gazebo?

Jose Luis Rivero gravatar imageJose Luis Rivero ( 2015-04-26 09:18:52 -0500 )edit

This is what I got after copying that command:ii gazebo2 2.2.5-1~trusty amd64 Gazebo simulator - Main package rc gazebo4 4.1.1-1~trusty amd64 Open Source Robotics Simulator

Haz88 gravatar imageHaz88 ( 2015-04-26 13:00:37 -0500 )edit

ii ros-indigo-gazebo-msgs 2.4.8-0trusty-20150326-1001-+0000 amd64 Message and service data structures for interacting with Gazebo from ROS.

Haz88 gravatar imageHaz88 ( 2015-04-26 13:00:43 -0500 )edit

rc libgazebo4:amd64 4.1.1-1~trusty amd64 Open Source Robotics Simulator - shared library

Haz88 gravatar imageHaz88 ( 2015-04-26 13:05:37 -0500 )edit

ii ros-indigo-gazebo-plugins 2.4.8-0trusty-20150328-2138-+0000 amd64 Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components.

Haz88 gravatar imageHaz88 ( 2015-04-26 13:07:29 -0500 )edit

ii ros-indigo-gazebo-ros 2.4.8-0trusty-20150328-2131-+0000 amd64 Provides ROS plugins that offer message and service publishers for interfacing with Gazebo through ROS. Formally simulator_gazebo/gazebo

Haz88 gravatar imageHaz88 ( 2015-04-26 13:07:54 -0500 )edit

ii ros-indigo-gazebo-ros-control 2.4.8-0trusty-20150328-2344-+0000 amd64 gazeboroscontrol ii ros-indigo-gazebo-ros-pkgs 2.4.8-0trusty-20150328-2334-+0000 amd64 Interface for using ROS with the Gazebo simulator.

Haz88 gravatar imageHaz88 ( 2015-04-26 13:08:02 -0500 )edit

Sorry for the countless posts, I'm limited to post small messages.

Haz88 gravatar imageHaz88 ( 2015-04-26 13:08:58 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted

answered 2022-08-31 04:22:23 -0500

  1. You can just delete the devel and build folder.
  2. Go to your <workspace>/src
  3. catkin_make
  4. Launch your file again.

This worked for me!

edit flag offensive delete link more

answered 2018-12-21 00:34:08 -0500

bonag gravatar image

If the problem still persists, update the setup_path variable in /opt/ros/lunar/lib/gazebo_ros/gzclient and /opt/ros/lunar/lib/gazebo_ros/gzserver to /usr/share/gazebo

Also, as mentioned in the other comment, "//" isn't the problem here. I tried without removing a "/" and it works fine.

edit flag offensive delete link more


it is not working still have same problem

ebinsunny gravatar imageebinsunny ( 2019-01-22 03:59:03 -0500 )edit

sorry if I sound dumb, but how to update the setup_path? I am new to ROS and Ubuntu.

edit: figured that out but problem still exists

SAGAR SHENOY gravatar imageSAGAR SHENOY ( 2020-10-28 01:30:11 -0500 )edit

type vim /opt/ros/lunar/lib/gazebo_ros/gzserver in terminal.

You will see the following line: setup_path=$(pkg-config --variable=prefix gazebo)/share/gazebo/ Replace this line with: setup_path=/usr/share/gazebo This did the trick for me

den-globotix gravatar imageden-globotix ( 2021-11-01 08:44:59 -0500 )edit

answered 2015-04-28 15:59:44 -0500

If you copy from your terminal for the error information and paste here:

"Can't open /usr/share/gazebo//"

Then you have two "//" before

edit flag offensive delete link more

Question Tools


Asked: 2015-04-24 09:01:18 -0500

Seen: 4,231 times

Last updated: Dec 21 '18