Gazebo | Ignition | Community
Ask Your Question

Roslaunch to Spawn URDF Robots

asked 2015-04-27 15:41:45 -0500

Haz88 gravatar image


I'm working on the 'Using roslaunch to start Gazebo, world files and URDF models' Tutorial and stuck at the '"ROS Service Call" Robot Spawn Method' section. The command of " rosrun gazeboros spawnmodel -file rospack find MYROBOT_description/urdf/MYROBOT.urdf -urdf -x 0 -y 0 -z 1 -model MYROBOT " results with the following error:

[rospack] Error: package 'MYROBOTdescription' not found spawnmodel script started Unable to register with master node [http://localhost:11311]: master may not be running yet. Will keep trying.

Awaiting for any advice, Haz88

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2017-11-15 23:29:16 -0500

Albert gravatar image

I met the same error. I solved it. I first run the command:roslaunch MYROBOT_gazebo MYROBOT.launch, then in another terminal I run the command:rosrun gazebo_ros spawn_model -file rospack find baxter_description/urdf/baxter.urdf -urdf -z 1 -model baxter, then I can see the baxter in the gazebo world. I don't know the reason, I guess it's caused by the mechanism of spawn_model. Wish it help.

edit flag offensive delete link more

answered 2015-04-28 22:44:54 -0500

winston gravatar image

updated 2015-04-28 22:48:56 -0500

It looks like you have missed `` for the "rospack find MYROBOT_description". Things inside it will be executed by bash f ...
edit flag offensive delete link more
Login/Signup to Answer

Question Tools


Asked: 2015-04-27 15:41:45 -0500

Seen: 2,015 times

Last updated: Apr 28 '15