Gazebo | Ignition | Community
Ask Your Question

Uncontrollable robot with bullet physics (works ok with ode)

asked 2015-05-21 09:12:35 -0600

niall gravatar image

updated 2015-05-21 09:13:16 -0600

I got hector_quadrotor working with gazebo5 (instead of gazebo2) to be able to experiment with different physics engines. While the quadrotor is controllable with ode (subscribing to cmd_vel) it doesn't respond when using the bullet engine. I checked the forces during the simulation and they are reporting penetration depths, normals and locations but all forces and torques are 0. Does anyone have any idea whats going on or how I can find out whats going on?

In addition, I tried using simbody physics engine and all my objects are suddenly placed at the center of the world?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2016-09-05 02:27:34 -0600

Georacer gravatar image

updated 2016-09-06 03:28:10 -0600

I have the same problem. My model responds fine with ODE but doesn't respond to API-set force and torques.

Test: I run an empty world with gazebo -e bullet and place any object on the scene, say the Coke can.

Then I right-click->apply force-torque and set any force. The model never moves.


Clarification: Running on Gazebo 7 installed from ROS Kinetic, from precompiled binaries. Does anyone know if Bullet still needs Gazebo compilation from source?


According to this Bullet is included in the current Gazebo binary.


I don't know which method the hector_quadrotor plugins use to move the model, but if they use AddRelativeForce or AddForce, then it may have to do with this

edit flag offensive delete link more
Login/Signup to Answer

Question Tools


Asked: 2015-05-21 09:12:35 -0600

Seen: 1,154 times

Last updated: Sep 06 '16