Gazebo | Ignition | Community
Ask Your Question

Unable to compile Gazebo with Dart. Bizarre error no static lib found error.

asked 2015-06-26 11:38:55 -0500

Skylion gravatar image

updated 2015-06-26 11:39:36 -0500

I was trying to compile Gazebo with Dart on Ubuntu 14.04, but alas I keep getting this bizarre error:

gazebo: error while loading shared libraries: cannot open shared object file: No such file or directory

Know, I know this error is very similar to one of the ones described in the tutorial for installing Gazebo, but that error is not .4. Moreover, I tried the solution suggested on that page:

echo '/usr/local/lib' | sudo tee /etc/ 
sudo ldconfig

but it did not work. Any idea how to resolve this error? I tried both following the directions on the websites and when that did not work, using the .sh script provided in the following git repo to do it, but that did not work. Any idea what could be causing my error?

edit retag flag offensive close merge delete


Did you check that is inside /usr/local/lib? Have you tried /usr/local/lib/x86_64-linux-gnu instead?

chapulina gravatar imagechapulina ( 2015-06-26 11:45:58 -0500 )edit

That worked, but now I am getting new errors:Error opening log file: "/home/skylion/.gazebo/gzserver.log" Error opening log file: "/home/skylion/.gazebo/default.log" Error opening log file: "/home/skylion/.gazebo/gzclient.log" Error opening log file: "/home/skylion/.gazebo/default.log" Qt has caught an exception thrown from an event handler. Throwing exceptions from an event handler is not supported in Qt. You must reimplement QApplication::notify() and catch all exceptions there.

terminate cal

Skylion gravatar imageSkylion ( 2015-06-26 11:58:46 -0500 )edit

humm maybe try deleting your log files? `rm ~/.gazebo/*.log`

chapulina gravatar imagechapulina ( 2015-06-26 12:03:22 -0500 )edit

Thank you, @chapulina your solution worked. If you write it up, I'll accept it in answer form. Update: I spoke too soon, it' s not running dart now: * Internal Program Error - assertion (dartChildLink.get() != __null) failed in virtual void gazebo::physics::DARTJoint::Init(): /home/skylion/gazebo/gazebo/physics/dart/ dartChildLink pointer is NULL. Regardless, since this is a different issue I have opened up a new question on the matter.

Skylion gravatar imageSkylion ( 2015-06-26 12:13:20 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2015-06-26 12:06:39 -0500

Jose Luis Rivero gravatar image

When building gazebo from source and installing it outside of /usr (i.e. /usr/local) the loader needs to know about where to find the libraries. To make it easy, gazebo provides the script. So:

  • Source the file in /usr/local installation (. /usr/local/share/gazebo/

  • Install gazebo (cmake .. -DCMAKE_INSTALL_PREFIX=/usr) into /usr will workaround about this kind of problems, if this is an option for you.

  • As Louise pointed in the comment, the library path used by gazebo is a arch-dependent path (i.e. /usr/local/lib/x86_64-linux-gnu on 64 bits systems). I won't recommend to use /etc/ for pointing it to /usr/local, it could end up in a security risk.

edit flag offensive delete link more


I tried source and my DCMAKE_INSTALL_PATH did equal /usr

Skylion gravatar imageSkylion ( 2015-06-26 12:08:36 -0500 )edit

Question Tools


Asked: 2015-06-26 11:38:55 -0500

Seen: 477 times

Last updated: Jun 26 '15