Gazebo | Ignition | Community
Ask Your Question

Failed to load plugin, no such file or directory, Gazebo 5.0 with ROS

asked 2015-06-29 08:39:21 -0500

MBauer gravatar image

Hi everyone,

I've been reading through many similar questions and trying their solutions however with no avail. I'm fairly new to Gazebo and while I've tried some other solutions, it may not have worked due to vagueness in the answer, differences over the different Gazebo versions or I may have simply missed something obvious. It seems upon trying to load any plugin, either my own or given Gazebo examples, it fails to load with the error below.

[Err] [Plugin.hh:153] Failed to load plugin cannot open shared object file: No such file or directory

I'm using Gazebo 5.0 with ROS, installed from source, running on Ubuntu, my GAZEBOPLUGINPATH was originally empty by default, It now contains "/home/elias/catkin_ws/devel"

Does anyone have any ideas or solutions?

Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2015-07-03 11:34:25 -0500

mikepurvis gravatar image

I was having some issues like this working with Gazebo 5 on Indigo. Unless you're on Jade, make sure that gazebo_ros is in your workspace.

edit flag offensive delete link more

Question Tools


Asked: 2015-06-29 08:39:21 -0500

Seen: 1,688 times

Last updated: Jul 03 '15