Gazebo | Ignition | Community
Ask Your Question

Gazebo in Groovy (1.2.5) does not use translation when spawning urdf model [closed]

asked 2013-01-21 09:10:55 -0500

Stefan Kohlbrecher gravatar image

updated 2013-01-25 04:02:27 -0500

In earlier ROS/Gazebo versions this:

<node name="spawn_robot" pkg="gazebo" type="spawn_model"
  args="-param robot_description
        -z 1.7
        -model robot_description"
  respawn="false" output="screen" />

would spawn a urdf model at position (0/0/1.7) in the gazebo world. This does not seem to be the case anymore with the current gazebo version installed from .debs in groovy. My robot model is always spawned to (0/0/0), which means it is severly clipping through the ground, in turn launching it into space every time I try to spawn it (or try to reset model poses, for that matter). Are there any known easy workarounds for that matter? Is the above methods of specifying a spawn position deprecated/unsupported now, or is the described behavior a bug?

As a side note, on startup, my gazebo says:

Gazebo multi-robot simulator, version 1.2.5

Looking at the changeset I would've expected to see 1.3.x , but apt-get says my .debs are up-to-date.

/edit: Wanted to test with Gazebo 1.3 from shadow-fixed repo. This does not currently work, however (see comments)

/edit: Just tested with Gazebo 1.3. The spawn height is honored there, unfortunately Gazebo instantly crashes with the semi-assembled robot floating in the air.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by nkoenig
close date 2013-07-24 11:27:13.006508


The answer to your 1.2.5 / 1.3.x question is that groovy was released in December 2012, so it has version 1.7.6 of that changelog - which is 1.2.5. 1.3 was switched to in 1.7.7

jamuraa gravatar imagejamuraa ( 2013-01-21 17:04:19 -0500 )edit

1.7.8 is still in shadow fixed, you can wait until it gets sync'd with the public repo, or If feeling adventurous, you can set your /etc/apt/sources.list.d/ros-latest.list to

deb precise main

sudo apt-get update

sudo apt-get dist-upgrade

hsu gravatar imagehsu ( 2013-01-22 09:31:05 -0500 )edit

I'm always feeling adventurous ;) Tried as you suggested, unfortunately the adventure comes to a sudden halt due to gazebo (or better, rospack) always complaining on gazebo startup: "[rospack] Error: stack/package simulator_gazebo not found". "roscd simulator_gazebo" works, however.

Stefan Kohlbrecher gravatar imageStefan Kohlbrecher ( 2013-01-24 04:11:43 -0500 )edit

Guess I'll wait a little and see if this is just a temporary hiccup in the shadow-fixed repo.

Stefan Kohlbrecher gravatar imageStefan Kohlbrecher ( 2013-01-24 04:13:12 -0500 )edit

I've found myself in the

simulator_gazebo not found

state before too. It seems to be because of some bash issue, failing to handle ros environment states properly. Do you still get the same problem if you try things out in a new terminal?

hsu gravatar imagehsu ( 2013-01-24 11:17:40 -0500 )edit

Could be a problem with the rospack cache stored in ~/.ros. ROS does not differentiate between releases. I had similar problems when switching between fuerte and groovy with the same packages at different locations. Deleting rospackcache or setting ROSHOME explicitly usually solves the problem.

Johannes Meyer gravatar imageJohannes Meyer ( 2013-01-24 14:09:25 -0500 )edit

Just created this Q/A: before seeing Johannes's suggestion ..trying it out.

Stefan Kohlbrecher gravatar imageStefan Kohlbrecher ( 2013-01-25 02:29:39 -0500 )edit

Nope, doesn't work. Everything else related to the rospack error should go into the newly created Q/A.

Stefan Kohlbrecher gravatar imageStefan Kohlbrecher ( 2013-01-25 02:37:26 -0500 )edit

thanks for looking into this Stafan.

hsu gravatar imagehsu ( 2013-01-25 09:56:20 -0500 )edit

updated groovy uses gazebo 1.5, can someone please test and report? Thanks!

hsu gravatar imagehsu ( 2013-07-23 18:20:10 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2013-01-25 06:12:55 -0500

Stefan Kohlbrecher gravatar image
edit flag offensive delete link more

Question Tools



Asked: 2013-01-21 09:10:55 -0500

Seen: 481 times

Last updated: Jan 25 '13