Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Cannot connect to Connection Manager.

Hello,

I have followed the installation guide here: http://gazebosim.org/wiki/1.4/install and installed Gazebo using the pre-compiled binaries for Ubuntu Linux 12.04 (precise). However, when I execute the following command:

bram@bram-progbak:~$ gazebo

I get the following output:

Gazebo multi-robot simulator, version 1.4.0 Copyright (C) 2013 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

Gazebo multi-robot simulator, version 1.4.0 Copyright (C) 2013 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

Msg Waiting for master.Msg Waiting for master...................................................................................................

And the dots go on forever. When I hit CTRL-C the following messages is displayed: Error [ConnectionManager.cc:89] Connection Manager is not running

I have also tried to use the Gazebo package which is integrated with ROS but the same happens there. The following environmental variables have been defined:

GAZEBO_MASTER_URI=http://localhost:11345 GAZEBO_MODEL_DATABASE_URI=http://gazebosim.org/models GAZEBO_PLUGIN_PATH=/usr/lib/gazebo-1.4/plugins GAZEBO_RESOURCE_PATH=/usr/share/gazebo-1.4:/usr/share/gazebo_models

Hope you guys can help me get the master server to run. Thanks! Bram

Cannot connect to Connection Manager.

Hello,

I have followed the installation guide here: http://gazebosim.org/wiki/1.4/install and installed Gazebo using the pre-compiled binaries for Ubuntu Linux 12.04 (precise). However, when I execute the following command:

bram@bram-progbak:~$ gazebo

I get the following output:

Gazebo multi-robot simulator, version 1.4.0 Copyright (C) 2013 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

Gazebo multi-robot simulator, version 1.4.0 Copyright (C) 2013 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

Msg Waiting for master.Msg Waiting for master...................................................................................................

And the dots go on forever. When I hit CTRL-C the following messages is displayed: Error [ConnectionManager.cc:89] Connection Manager is not running

I have also tried to use the Gazebo package which is integrated with ROS but the same happens there. The following environmental variables have been defined:

GAZEBO_MASTER_URI=http://localhost:11345 GAZEBO_MODEL_DATABASE_URI=http://gazebosim.org/models GAZEBO_PLUGIN_PATH=/usr/lib/gazebo-1.4/plugins GAZEBO_MASTER_URI=http://localhost:11345

GAZEBO_MODEL_DATABASE_URI=http://gazebosim.org/models

GAZEBO_PLUGIN_PATH=/usr/lib/gazebo-1.4/plugins

GAZEBO_RESOURCE_PATH=/usr/share/gazebo-1.4:/usr/share/gazebo_models

Here is the tracelog when I try to run gzmaster:

bram@bram-progbak:~/builds/gazebo-1.4.0/build$ gdb gzmaster
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/local/bin/gzmaster...done.
(gdb) run
Starting program: /usr/local/bin/gzmaster 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffeceb9700 (LWP 5329)]
Gazebo multi-robot simulator, version 1.4.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org


Program received signal SIGSEGV, Segmentation fault.
gazebo::Master::Init (this=0x0, _port=11345) at /home/bram/builds/gazebo-1.4.0/gazebo/Master.cc:65
65      this->connection->Listen(_port, boost::bind(&Master::OnAccept, this, _1));
(gdb) wher
#0  gazebo::Master::Init (this=0x0, _port=11345) at /home/bram/builds/gazebo-1.4.0/gazebo/Master.cc:65
#1  0x000000000040f39b in main () at /home/bram/builds/gazebo-1.4.0/gazebo/master_main.cc:58
(gdb)

Hope you guys can help me get the master server to run. Thanks! Thanks!

Bram

Cannot connect to Connection Manager.

Hello,

I have followed the installation guide here: http://gazebosim.org/wiki/1.4/install http://gazebosim.org/wiki/1.4/install and installed Gazebo using the pre-compiled binaries for Ubuntu Linux 12.04 (precise). However, when I execute the following command:

bram@bram-progbak:~$ gazebo

gazebo

I get the following output:

Gazebo multi-robot simulator, version 1.4.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org

http://gazebosim.org Gazebo multi-robot simulator, version 1.4.0 Copyright (C) 2013 Open Source Robotics Foundation. Released under the Apache 2 License. http://gazebosim.org

http://gazebosim.org Msg Waiting for master.Msg Waiting for master...................................................................................................

master...................................................................................................

And the dots go on forever. When I hit CTRL-C the following messages is displayed: Error [ConnectionManager.cc:89] Connection Manager is not running

I have also tried to use the Gazebo package which is integrated with ROS but the same happens there. The following environmental variables have been defined:

GAZEBO_MASTER_URI=http://localhost:11345

GAZEBO_MODEL_DATABASE_URI=http://gazebosim.org/models

GAZEBO_PLUGIN_PATH=/usr/lib/gazebo-1.4/plugins

GAZEBO_RESOURCE_PATH=/usr/share/gazebo-1.4:/usr/share/gazebo_models

GAZEBO_MASTER_URI=http://localhost:11345

GAZEBO_MODEL_DATABASE_URI=http://gazebosim.org/models

GAZEBO_PLUGIN_PATH=/usr/lib/gazebo-1.4/plugins

GAZEBO_RESOURCE_PATH=/usr/share/gazebo-1.4:/usr/share/gazebo_models

Here is the tracelog when I try to run gzmaster:

bram@bram-progbak:~/builds/gazebo-1.4.0/build$ gdb gzmaster
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2.1) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/local/bin/gzmaster...done.
(gdb) run
Starting program: /usr/local/bin/gzmaster 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffeceb9700 (LWP 5329)]
Gazebo multi-robot simulator, version 1.4.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.
http://gazebosim.org


Program received signal SIGSEGV, Segmentation fault.
gazebo::Master::Init (this=0x0, _port=11345) at /home/bram/builds/gazebo-1.4.0/gazebo/Master.cc:65
65      this->connection->Listen(_port, boost::bind(&Master::OnAccept, this, _1));
(gdb) wher
#0  gazebo::Master::Init (this=0x0, _port=11345) at /home/bram/builds/gazebo-1.4.0/gazebo/Master.cc:65
#1  0x000000000040f39b in main () at /home/bram/builds/gazebo-1.4.0/gazebo/master_main.cc:58
(gdb)

Hope you guys can help me get the master server to run. Thanks!

Bram