Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

E: Unable to correct problems, you have held broken package

When I finished installing ROS Indigo, I noticed that it already came with Gazebo(version2.2.6). If I directly install the 6.0 Gazebo, is it possible that the 6.0 version and 2.2.6 version will conflict with each other?

Actually, I have tried to install gazebo as described in http://gazebosim.org/tutorials?tut=install_ubuntu&ver=6.0&cat=install

but, it says that : E: Unable to correct problems, you have held broken package

It looks like that I have Gazebo(version2.2.6) cause this problem (gazebo which command indicate tha I have Gazebo(version2.2.6)

How can I remove Gazebo(version2.2.6) came with ROS indigo?

My situation is as follows:

wkyoun@wkyoun-XPS-13-9343:~$ sudo apt-get install gazebo6 Reading package lists... Done Building dependency tree
Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: gazebo6 : Depends: libgazebo6 (= 6.5.1-1~trusty) but it is not going to be installed

       Depends: libsdformat3 but it is not going to be installed
       Depends: gazebo6-common (= 6.5.1-1~trusty) but it is not going to be installed
       Recommends: gazebo6-plugin-base

E: Unable to correct problems, you have held broken packages.