Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

The plugin SkidSteerDrivePlugin did not work on pioneer3at model in gazebo 5

Hi,all: I added the plugin in pioneer3at model like this: <model name="pioneer3at"> ... <static>0</static> ... <plugin name="SkidSteerDrivePlugin" filename="libSkidSteerDrivePlugin.so"> <right_front>right_front</right_front> <right_rear>right_rear</right_rear> <left_front>left_front</left_front> <left_rear>left_rear</left_rear> <maxforce>5.0</maxforce> </plugin> </model> But when I run the gazebo and then publish topic'~/pioneer3at/vel_cmd' using rqt_gui, the pioneer did not move.Also, any possible topic name has been tried. Anyone know why the pioneer did not move?

The plugin SkidSteerDrivePlugin did not work on pioneer3at model in gazebo 5

Hi,all: I added the plugin in pioneer3at model like this: this:

   <model name="pioneer3at">
name='pioneer3at'>
      ...
      <static>0</static>
      ...
      <plugin name="SkidSteerDrivePlugin" filename="libSkidSteerDrivePlugin.so">
name='SkidSteerDrivePlugin' filename='libSkidSteerDrivePlugin.so'>
        <right_front>right_front</right_front>
        <right_rear>right_rear</right_rear>
        <left_front>left_front</left_front>
        <left_rear>left_rear</left_rear>
        <maxforce>5.0</maxforce>
<MaxForce>5.0</MaxForce>
      </plugin>
    </model>

But when I run the gazebo and then publish topic'~/pioneer3at/vel_cmd' using rqt_gui, the pioneer did not move.Also, any possible topic name has been tried. Anyone know why the pioneer did not move?