Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Gazebo Not Respond after Deleting models!

I write a model plugin for my soccer-playing robot. I can successful spawn it into my simulation world. However, when I delete this model, the model is removed from the world, but then Gazebo does not respond anymore. I click everywhere and nothing happens. So I have to Ctrl-C in the terminal and it throws out a message like this:

[gazebo-2] killing on exit
gzclient: /usr/include/boost/smart_ptr/shared_ptr.hpp:653: typename boost::detail::sp_member_access<T>::type boost::shared_ptr<T>::operator->() const [with T = gazebo::msgs::Response; typename boost::detail::sp_member_access<T>::type = gazebo::msgs::Response*]: Assertion `px != 0' failed.
[gazebo_gui-3] escalating to SIGTERM
[gazebo-2] escalating to SIGTERM
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

I am using Gazebo 7 with gazebo_ros_pkgs. Indeed I use ROS in my model plugin. But does it matter?

Any suggestions would be greatly appreciated!

Gazebo Not Respond after Deleting models!

I write a model plugin for my soccer-playing robot. I can successful spawn it into my simulation world. However, when I delete this model, the model is removed from the world, but then Gazebo does not respond anymore. I click everywhere and nothing happens. So I have to Ctrl-C in the terminal and it throws out a message like this:

[gazebo-2] killing on exit
gzclient: /usr/include/boost/smart_ptr/shared_ptr.hpp:653: typename boost::detail::sp_member_access<T>::type boost::shared_ptr<T>::operator->() const [with T = gazebo::msgs::Response; typename boost::detail::sp_member_access<T>::type = gazebo::msgs::Response*]: Assertion `px != 0' failed.
[gazebo_gui-3] escalating to SIGTERM
[gazebo-2] escalating to SIGTERM
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

I am using Gazebo 7 with gazebo_ros_pkgs. Indeed I use ROS in my model plugin. But does it matter?

Any suggestions would be greatly appreciated!

EDIT: I need the answer to this question eagerly. So please anyone give me some advice.

Gazebo Not Respond after Deleting models!

I write a model plugin for my soccer-playing robot. I can successful spawn it into my simulation world. However, when I delete this model, the model is removed from the world, but then Gazebo does not respond anymore. I click everywhere and nothing happens. So I have to Ctrl-C in the terminal and it throws out a message like this:

[gazebo-2] killing on exit
gzclient: /usr/include/boost/smart_ptr/shared_ptr.hpp:653: typename boost::detail::sp_member_access<T>::type boost::shared_ptr<T>::operator->() const [with T = gazebo::msgs::Response; typename boost::detail::sp_member_access<T>::type = gazebo::msgs::Response*]: Assertion `px != 0' failed.
[gazebo_gui-3] escalating to SIGTERM
[gazebo-2] escalating to SIGTERM
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

I am using Gazebo 7 with gazebo_ros_pkgs. Indeed I use ROS in my model plugin. But does it matter?

Any suggestions would be greatly appreciated!

EDIT: I need the answer to this question eagerly. So please anyone give me some advice.

Gazebo IMPORTANT!Gazebo Not Respond after Deleting models!

I write a model plugin for my soccer-playing robot. I can successful spawn it into my simulation world. However, when I delete this model, the model is removed from the world, but then Gazebo does not respond anymore. I click everywhere and nothing happens. So I have to Ctrl-C in the terminal and it throws out a message like this:

[gazebo-2] killing on exit
gzclient: /usr/include/boost/smart_ptr/shared_ptr.hpp:653: typename boost::detail::sp_member_access<T>::type boost::shared_ptr<T>::operator->() const [with T = gazebo::msgs::Response; typename boost::detail::sp_member_access<T>::type = gazebo::msgs::Response*]: Assertion `px != 0' failed.
[gazebo_gui-3] escalating to SIGTERM
[gazebo-2] escalating to SIGTERM
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

I am using Gazebo 7 with gazebo_ros_pkgs. Indeed I use ROS in my model plugin. But does it matter?

Any suggestions would be greatly appreciated!

EDIT: I need the answer to this question eagerly. So please anyone give me some advice.

IMPORTANT!Gazebo Not Respond after Deleting models!

I write a model plugin for my soccer-playing robot. I can successful spawn it into my simulation world. However, when I delete this model, the model is removed from the world, but then Gazebo does not respond anymore. I click everywhere and nothing happens. So I have to Ctrl-C in the terminal and it throws out a message like this:

[gazebo-2] killing on exit
gzclient: /usr/include/boost/smart_ptr/shared_ptr.hpp:653: typename boost::detail::sp_member_access<T>::type boost::shared_ptr<T>::operator->() const [with T = gazebo::msgs::Response; typename boost::detail::sp_member_access<T>::type = gazebo::msgs::Response*]: Assertion `px != 0' failed.
[gazebo_gui-3] escalating to SIGTERM
[gazebo-2] escalating to SIGTERM
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

I am using Gazebo 7 with gazebo_ros_pkgs. Indeed I use ROS in my model plugin. But does it matter?

Any suggestions would be greatly appreciated!

EDIT: I need the answer to this question eagerly. So please anyone give me some advice.