Home | Tutorials | Wiki | Issues
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Why does my robot fall so slowly if I enable gazebo_ros_control plugin?

I'm using the Nao simulation (https:/github.com/ros-naoqi/nao_robot) with Kinetic and Gazebo 7.

The default launch spawns the robot in the air. The simulation runs slower than real time, but the robot takes almost 30 seconds of simulation time to fall less than 0.2 meters.

If I comment out the invocation of the gazebo_ros_control plugin from the xacro file, then the robot falls to the ground quickly as expected. This slow falling of the main body happens whether I enable any controllers or not.

Any ideas what is causing this issue?

image description (Note the timestamp on image when the robot first touched down.)

Originally the default installation would fall slowly backwards, as shown in the attached image. I fixed the falling backwards by updating some of the dynamics parameters in the urdf, but I have not been able to determine the slow falling.

Why does my robot fall so slowly if I enable gazebo_ros_control plugin?

I'm using the Nao simulation (https:/github.com/ros-naoqi/nao_robot) with Kinetic and Gazebo 7.

The default launch spawns the robot in the air. The simulation runs slower than real time, but the robot takes almost 30 seconds of simulation time to fall less than 0.2 meters.

If I comment out the invocation of the gazebo_ros_control plugin from the xacro file, then the robot falls to the ground quickly as expected. This slow falling of the main body happens whether I enable any controllers or not.

Any ideas what is causing this issue?

image description (Note the timestamp on image when the robot first touched down.)

Originally the default installation would fall slowly backwards, as shown in the attached image. I fixed the falling backwards by updating some of the dynamics parameters in the urdf, but I have not been able to determine the slow falling.