Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Problem with reading inertia values from sdf in Gazebo

Hi there, I have a problem with defining inertia in the model sdf file. Everything is as in the code below, but when I import the model into Gazebo, it seems as if the program disregards everything in the intertial tags and inserts its own values. Is there something very obvious that I am missing?

image description

<?xml version='1.0'?>
<sdf version="1.4">
<model name="Mymodel">
    <pose>0 0 0.0 0 0 0</pose>
    <static>true</static>
        <link name="body">
            <inertial>
                <mass>0.002</mass>
                <inertia>
                    <ixx>0.000000420478</ixx> 
                    <ixy>0.0</ixy>         
                    <ixz>0.0</ixz>         
                    <iyy>0.000000091134</iyy>      
                    <iyz>0.0</iyz>        
                    <izz>0.000000404044</izz>      
                </inertia>
            </inertial>
            <collision name="collision">
                <geometry>
                    <box>
                        <size>0.015 0.047 0.018</size>
                    </box>
                </geometry>
             </collision>
             <visual name="visual">
                <geometry>
                   <mesh>
                       <uri>model:///mymodel/meshes/mymodel.stl</uri>
                   </mesh>
                </geometry>
             </visual>
      </link>
</model>
</sdf>