Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Gazebo crashing in Ubuntu via VMware

So I run Gazebo on VMware (Ubuntu 16.04 LTS) and for some reason it crashes after I use certain topics (in this case I tried scan for environment and get readings from /scan topic) or open RVIZ. It crashes with this type of error:

[gazebo-1] process has died [pid 10985, exit code 134, cmd /opt/ros/kinetic/lib/gazebo_ros/gzserver -e ode /opt/ros/kinetic/share/turtlebot_gazebo/worlds/ __name:=gazebo __log:=/home/ilja/.ros/log/9fe3ccc0-bd9d-11e7-b23e-000c294d0ea7/gazebo-1.log]. log file: /home/ilja/.ros/log/9fe3ccc0-bd9d-11e7-b23e-000c294d0ea7/gazebo-1*.log

Can't find this log either gazebo-1*.log. Is the problem in VMWare? VMWare specs: 4GB RAM, 1 processor Intel VT-x mode, accelerate 3D graphics off, default graphic drivers on Ubuntu.

I can move turtlebot via telemetry, also I subscribe to topics and get the data in Matlab. But sometimes when system idle Gazebo crashes.