Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

gazebo-9 gui doesn't launch


I recently un-installed my copy of gazebo 7 that came with my installation of ros kinetic (desktop full) on my Ubuntu 16.04 system. It was crashing on launch and I attributed that to this issue based on Sharvashish Das's comment (I could have been totally wrong but I didn't really document my error tracking process.) I knew I needed to upgrade to gazebo 9 at some point anyway (project reasons) so I decided to install it from source based on the tutorial here. I also installed the dependent libraries from source as the tutorial suggested. I made sure that ros was not sourced during this whole process as the tutorial suggests.

Everything built and was installed in my usr/local/ directory. However, when I tried to launch gazebo it did nothing.

I tried to run the executable directly from usr/local/bin and still nothing

It seems that I can launch the gzserver executable. Here is the verbose output:

But I get a Segmentation fault (core dumped) output from the gzclient:

I read somewhere that this error could be fixed by installing the latest proprietary Nvidia drivers. I have a Nvidia GTX-970 graphics card, and found that the latest driver was the nvidia-390.25. I installed it, and made sure it was running:

but I'm still getting the same results. I'm not really sure what to do next. Try un-installing and re-installing? Un-install ros and gazebo and re-install gazebo-9 first? Is there something obvious I'm missing and I can avoid that all together?

As a side note. The install from source tutorial has you download and build everything from the /tmp directory, and then says to do sudo make uninstall from the build directory if you want to un-install. In my case, those directories got wiped when I had to reboot for the graphics drivers to update. I made local copies of these directories before I rebooted, but I'm still confused as to why they would have you do all this in the /tmp folder in the first place? I'm still somewhat new to Linux and don't do much building from source, so maybe that's a newbie question.