Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Exporting from Blender (Collada), Texture won't load in Gazebo

Hello!

I am trying to import the model made and textured in Blender into the Gazebo, which works fine, except I'm having troubles exporting the texture somehow...

here's the blend file: https://mega.nz/#!OtQVmKqa!UhZTc6RKAt1Ztxz38ubBLwyX4dbIbXbydkibN9wXONY

and here's the texture: https://mega.nz/#!7hQznCpT!XpTc2kEFqkP6Inim0E1banWzIIZQn4qri3SAD7F00EU

I'm exporting to Collada and I've tried different export settings - the object is either dark gray, or completely white

I followed this tutorial https://www.youtube.com/watch?v=LcCQKuWPhXk when making textures...

when I export it to collada and specify texture options (when exporting) as 'Materials' and copy, the result is a dark gray wall, using 'UV Textures' instead of 'Materials' makes the wall white

I've never really worked with Blender nor Gazebo before, so I'm not sure where is the problem

Exporting from Blender (Collada), Texture won't load in Gazebo

Hello!

I am trying to import the model made and textured in Blender into the Gazebo, which works fine, except I'm having troubles exporting the texture somehow...

here's the both blend file: https://mega.nz/#!OtQVmKqa!UhZTc6RKAt1Ztxz38ubBLwyX4dbIbXbydkibN9wXONY

file (wall.blend) and here's the texture: https://mega.nz/#!7hQznCpT!XpTc2kEFqkP6Inim0E1banWzIIZQn4qri3SAD7F00EUtexture (WallTexture.png) can be found here: https://mega.nz/#F!WtpCjBwZ!lIqWvRrfdTcCDj_FtKiBJg

I'm exporting to Collada and I've tried different export settings - the object is either dark gray, or completely white

I followed this tutorial https://www.youtube.com/watch?v=LcCQKuWPhXk when making textures...

when I export it to collada and specify texture options (when exporting) as 'Materials' and copy, the result is a dark gray wall, using 'UV Textures' instead of 'Materials' makes the wall white

I've never really worked with Blender nor Gazebo before, so I'm not sure where is the problem

Exporting from Blender (Collada), Texture won't load in Gazebo

Hello!

I am trying to import the model made and textured in Blender into the Gazebo, which works fine, except I'm having troubles exporting the texture somehow...

both blend file (wall.blend) and texture (WallTexture.png) can be found here: https://mega.nz/#F!WtpCjBwZ!lIqWvRrfdTcCDj_FtKiBJg

I'm exporting to Collada and I've tried different export settings - the object is either dark gray, or completely white

I followed this tutorial https://www.youtube.com/watch?v=LcCQKuWPhXk when making textures...

when I export it to collada and specify texture options (when exporting) as 'Materials' and copy, the result is a dark gray wall, using 'UV Textures' instead of 'Materials' makes the wall white

I have a launch file that loads world specified in https://pastebin.com/31GvWRC4 it loads several walls and pillars, making a rectangle

I've never really worked with Blender nor Gazebo before, so I'm not sure where is the problem

Exporting from Blender (Collada), Texture won't load in Gazebo

Hello!

I am trying to import the model made and textured in Blender into the Gazebo, which works fine, except I'm having troubles exporting the texture somehow...

both blend file (wall.blend) and texture (WallTexture.png) can be found here: https://mega.nz/#F!WtpCjBwZ!lIqWvRrfdTcCDj_FtKiBJg

I'm exporting to Collada and I've tried different export settings - the object is either dark gray, or completely white

I followed this tutorial https://www.youtube.com/watch?v=LcCQKuWPhXk when making textures...

when I export it to collada and specify texture options (when exporting) as 'Materials' and copy, the result is a dark gray wall, using 'UV Textures' instead of 'Materials' makes the wall white

for importing I used this tutorial: http://gazebosim.org/tutorials?tut=import_mesh I have a launch file that loads world specified in https://pastebin.com/31GvWRC4 it loads several walls and pillars, making a rectangle

I've never really worked with Blender nor Gazebo before, so I'm not sure where is the problem