Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

cmd_vel topic can be manipulated but no messages are received

Using ROS Kinect + Gazebo 7 I'm controlling an AR.Drone. Everything works fine, I can move the drone using the teleop_twist_keyboard or using a Python script done by me, but when I try to see the cmd_vel topic (rostopic echo), this happens:

rostopic echo /quadrotor/cmd_vel

WARNING: no messages received and simulated time is active.
Is /clock being published?

/clock is being published, and /quadrotor/cmd_vel is the name of the topic. What can I do? To move the drone using the teleop_twist_keyboard I use the following:

rosrun teleop_twist_keyboard teleop_twist_keyboard.py cmd_vel:=/quadrotor/cmd_vel

I hope you can help me. Thanks!

cmd_vel topic can be manipulated but no messages are received

Using ROS Kinect + Gazebo 7 I'm controlling an AR.Drone. Everything works fine, I can move the drone using the teleop_twist_keyboard or using a Python script done by me, but when I try to see the cmd_vel topic (rostopic echo), this happens:

rostopic echo /quadrotor/cmd_vel

WARNING: no messages received and simulated time is active.
Is /clock being published?

/clock is being published, and /quadrotor/cmd_vel is the name of the topic. What can I do? To move the drone using the teleop_twist_keyboard I use the following:

rosrun teleop_twist_keyboard teleop_twist_keyboard.py cmd_vel:=/quadrotor/cmd_vel

and I can also publish in that topic like:

rostopic pub -r 10 /quadrotor/cmd_vel geometry_msgs/Twist  '{linear:  {x: 0.1, y: 0.0, z: 0.0}, angular: {x: 0.0,y: 0.0,z: 0.0}}'

I hope you can help me. Thanks!