Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

How to turn of the green line-based light visualization? [Gazebo9]

I'm using a low poly .obj model that approximates geometry using double-sided faces with transparent textures (or, it should, once the issue with transparency described in Gazebo Bitbucket issue 404 is fixed). To render these parts correctly, backface culling needs to be disabled for the model. How can this be achieved?

See image below. Only the front-facing railings of the walkways are visible, although the model has railings on both sides of the walkways.

image description

How to turn of the green line-based light visualization? [Gazebo9]

I'm using a low poly .obj model that approximates geometry using double-sided faces with transparent textures (or, it should, once the issue with transparency described in Gazebo Bitbucket issue 404 is fixed). To render these parts correctly, backface culling needs to be disabled for the model. How can this be achieved?

See image below. Only the front-facing railings of the walkways are visible, although the model has railings on both sides of the walkways.

image description

How to turn of the green line-based light visualization? Turning off backface culling for a model [Gazebo9]

I'm using a low poly .obj model that approximates geometry using double-sided faces with transparent textures (or, it should, once the issue with transparency described in Gazebo Bitbucket issue 404 is fixed). To render these parts correctly, backface culling needs to be disabled for the model. How can this be achieved?

See image below. Only the front-facing railings of the walkways are visible, although the model has railings on both sides of the walkways.

image description

/edit: So I found out that using a custom material, backface culling can be switched off. This is done for instance in for the oak tree model in oak_tree.material. I can add a custom material to my model, but then the texture and material info from the COLLADA file are not used anymore. Any hints on how I can combine the material data from the COLLADA file, but switch off backface culling also?