Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Gravity doesnt pull my Model

Hello Everyone,

I am running Gazebo version 9.5.0 in an Ubuntu 18.04 LTS.

I build my own Model and tried to control it with an self written plugin. The Plugin applies a small force on the x-Vector. And the Model is moving in this direction. But it seems like it is not affected by gravity, also it is not static? I made a model and used the follower plugin from the tutorials witch behaves normal. Other objects are effected by gravity as well. It seems like the problem is in my Plugin.

I put the Model, Plugin and a short video in the attachments for you to check out. Maybe you are able to tell me what i am missing out.

I am new to gazebo and i hope you can help me.

Thank you Delay Lama

Gravity doesnt pull my Model

Hello Everyone,

I am running Gazebo version 9.5.0 in an Ubuntu 18.04 LTS.

I build my own Model and tried to control it with an self written plugin. The Plugin applies a small force on the x-Vector. And the Model is moving in this direction. But it seems like it is not affected by gravity, also it is not static? I made a model and used the follower plugin from the tutorials witch behaves normal. Other objects are effected by gravity as well. It seems like the problem is in my Plugin.

I put the Model, Plugin and a short video in the attachments for you to check out. Maybe you are able to tell me what i am missing out.

I am new to gazebo and i hope you can help me.

Thank you Delay Lama

EDIT: It seems to be, that there is an error while running gazebo, which might be in relation to the Problem [ Node::Advertise(): Error advertising a topic. Did you forget to start the discovery service? ]

Gravity doesnt pull my Model

Hello Everyone,

I am running Gazebo version 9.5.0 in an Ubuntu 18.04 LTS.

I build my own Model and tried to control it with an self written plugin. The Plugin applies a small force on the x-Vector. And the Model is moving in this direction. But it seems like it is not affected by gravity, also it is not static? I made a model and used the follower plugin from the tutorials witch behaves normal. Other objects are effected by gravity as well. It seems like the problem is in my Plugin.

I put the Model, Plugin and a short video in the attachments for you to check out. Maybe you are able to tell me what i am missing out.

I am new to gazebo and i hope you can help me.

Thank you Delay Lama

EDIT: It seems to be, that there is an error while running gazebo, which might be in relation to the Problem [ Node::Advertise(): Error advertising a topic. Did you forget to start the discovery service? ]

Gravity doesnt pull my Model

Hello Everyone,

I am running Gazebo version 9.5.0 in an Ubuntu 18.04 LTS.

I build my own Model and tried to control it with an self written plugin. The Plugin applies a small force on the x-Vector. And the Model is moving in this direction. But it seems like it is not affected by gravity, also it is not static? I made a model and used the follower plugin from the tutorials witch behaves normal. Other objects are effected by gravity as well. It seems like the problem is in my Plugin.

I put the Model, Plugin and a short video in the attachments for you to check out. Maybe you are able to tell me what i am missing out.

I am new to gazebo and i hope you can help me.

Thank you Delay Lama

EDIT: It seems to be, that there is an error while running gazebo, which might be in relation to the Problem [ Node::Advertise(): Error advertising a topic. Did you forget to start the discovery service? ]][C:\fakepath\model_push.cc]

(/upfiles/15442086922928567.cc)

Gravity doesnt pull my Model

Hello Everyone,

I am running Gazebo version 9.5.0 in an Ubuntu 18.04 LTS.

I build my own Model and tried to control it with an self written plugin. The Plugin applies a small force on the x-Vector. And the Model is moving in this direction. But it seems like it is not affected by gravity, also it is not static? I made a model and used the follower plugin from the tutorials witch behaves normal. Other objects are effected by gravity as well. It seems like the problem is in my Plugin.

I put the Model, Plugin and a short video in the attachments for you to check out. Maybe you are able to tell me what i am missing out.

I am new to gazebo and i hope you can help me.

Thank you Delay Lama

EDIT: It seems to be, that there is an error while running gazebo, which might be in relation to the Problem [ Node::Advertise(): Error advertising a topic. Did you forget to start the discovery service? ][C:\fakepath\model_push.cc]

(/upfiles/15442086922928567.cc)]

C:\fakepath\model_push.cc

Gravity doesnt pull my Model

Hello Everyone,

I am running Gazebo version 9.5.0 in an Ubuntu 18.04 LTS.

I build my own Model and tried to control it with an self written plugin. The Plugin applies a small force on the x-Vector. And the Model is moving in this direction. But it seems like it is not affected by gravity, also it is not static? I made a model and used the follower plugin from the tutorials witch behaves normal. Other objects are effected by gravity as well. It seems like the problem is in my Plugin.

I put the Model, Plugin and a short video in the attachments for you to check out. Maybe you are able to tell me what i am missing out.

I am new to gazebo and i hope you can help me.

Thank you Delay Lama

EDIT: It seems to be, that there is an error while running gazebo, which might be in relation to the Problem [ Node::Advertise(): Error advertising a topic. Did you forget to start the discovery service? ]

Plugin: C:\fakepath\model_push.cc Model: C:\fakepath\model.sdf

Gravity doesnt pull my Model

Hello Everyone,

I am running Gazebo version 9.5.0 in an Ubuntu 18.04 LTS.

I build my own Model and tried to control it with an self written plugin. The Plugin applies a small force on the x-Vector. And the Model is moving in this direction. But it seems like it is not affected by gravity, also it is not static? I made a model and used the follower plugin from the tutorials witch behaves normal. Other objects are effected by gravity as well. It seems like the problem is in my Plugin.

I put the Model, Plugin and a short video in the attachments for you to check out. Maybe you are able to tell me what i am missing out.

I am new to gazebo and i hope you can help me.

Thank you Delay Lama

EDIT: It seems to be, that there is an error while running gazebo, which might be in relation to the Problem [ Node::Advertise(): Error advertising a topic. Did you forget to start the discovery service? ]

Plugin: C:\fakepath\model_push.cc

Model: C:\fakepath\model.sdf

Das Video: https://s31.aconvert.com/convert/p3r68-cdx67/nauqc-5xle7.gif

Gravity doesnt pull my Model

Hello Everyone,

I am running Gazebo version 9.5.0 in an Ubuntu 18.04 LTS.

I build my own Model and tried to control it with an self written plugin. The Plugin applies a small force on the x-Vector. And the Model is moving in this direction. But it seems like it is not affected by gravity, also it is not static? I made a model and used the follower plugin from the tutorials witch behaves normal. Other objects are effected by gravity as well. It seems like the problem is in my Plugin.

I put the Model, Plugin and a short video in the attachments for you to check out. Maybe you are able to tell me what i am missing out.

I am new to gazebo and i hope you can help me.

Thank you Delay Lama

EDIT: It seems to be, that there is an error while running gazebo, which might be in relation to the Problem [ Node::Advertise(): Error advertising a topic. Did you forget to start the discovery service? ]

Plugin: C:\fakepath\model_push.cc

Model: C:\fakepath\model.sdf

Das Video: https://s31.aconvert.com/convert/p3r68-cdx67/nauqc-5xle7.gifhttps://s31.aconvert.com/convert/p3r68-cdx67/nauqc-5xle7.gif [If the link becomes invalid i will upload the video to a website, but the .gif is to big to upload here, i guess]

Gravity doesnt pull my Model

Hello Everyone,

I am running Gazebo version 9.5.0 in an Ubuntu 18.04 LTS.

I build my own Model and tried to control it with an self written plugin. The Plugin applies a small force on the x-Vector. And the Model is moving in this direction. But it seems like it is not affected by gravity, also it is not static? I made a model and used the follower plugin from the tutorials witch behaves normal. Other objects are effected by gravity as well. It seems like the problem is in my Plugin.

I put the Model, Plugin and a short video in the attachments for you to check out. Maybe you are able to tell me what i am missing out.

I am new to gazebo and i hope you can help me.

Thank you Delay Lama

EDIT: It seems to be, that there is an error while running gazebo, which might be in relation to the Problem [ Node::Advertise(): Error advertising a topic. Did you forget to start the discovery service? ]

Plugin: C:\fakepath\model_push.cc

Model: C:\fakepath\model.sdf

Das Video: https://s31.aconvert.com/convert/p3r68-cdx67/nauqc-5xle7.gif [If the link becomes invalid i will upload the video to a website, but the .gif is to big to upload here, i guess]https://youtu.be/AcG3D7kpQo8