Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

MoveIt setup assistant crashes during collision matrix building

I am trying to use MoveIt! with a custom robot. I have buit a simple one arm robot that can rotate around 2 axes.

I have installed the MoveIt!, built the robot and now I want to generate the moveit files using the MoveIt setup assistant. When I load the model description into the assistant, the whore robot is red.

image description

When I click the Create Collision Matrix button in the Self-Collisions tab, the assistant crashes. Closes itself and prints on the terminal only, that the process has died. The terminal outputs speaks about a log, but this log was not created. So I don't even know what error I got.

image description

the full terminal output:

linux@linux-Precision-T1650:~/catkin_ws/src$ roslaunch moveit_setup_assistant setup_assistant.launch
... logging to /home/linux/.ros/log/cd4f6daa-6115-11e9-9392-b8ca3aa30f44/roslaunch-linux-Precision-T1650-29494.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://linux-Precision-T1650:41067/

SUMMARY
========

PARAMETERS
 * /rosdistro: kinetic
 * /rosversion: 1.12.14

NODES
  /
    moveit_setup_assistant (moveit_setup_assistant/moveit_setup_assistant)

auto-starting new master
process[master]: started with pid [29508]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to cd4f6daa-6115-11e9-9392-b8ca3aa30f44
process[rosout-1]: started with pid [29522]
started core service [/rosout]
process[moveit_setup_assistant-2]: started with pid [29534]
[rospack] Error: no package given
[librospack]: error while executing command
xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order
[ INFO] [1555508218.850993372]: Loaded robotic_arm robot model.
[ INFO] [1555508218.851097573]: Setting Param Server with Robot Description
[ INFO] [1555508218.860170230]: Robot semantic model successfully loaded.
[ INFO] [1555508218.860221031]: Setting Param Server with Robot Semantic Description
[ INFO] [1555508218.894222163]: Loading robot model 'robotic_arm'...
[ INFO] [1555508218.894272202]: No root/virtual joint specified in SRDF. Assuming fixed joint
[ INFO] [1555508219.506530968]: Stereo is NOT SUPPORTED
[ INFO] [1555508219.506640640]: OpenGl version: 4.6 (GLSL 4.6).
[ INFO] [1555508219.734681131]: Loading robot model 'robotic_arm'...
[ INFO] [1555508219.734724579]: No root/virtual joint specified in SRDF. Assuming fixed joint
[ INFO] [1555508219.890169560]: Loading Setup Assistant Complete
================================================================================REQUIRED process [moveit_setup_assistant-2] has died!
process has died [pid 29534, exit code -11, cmd /home/linux/catkin_ws/devel/lib/moveit_setup_assistant/moveit_setup_assistant __name:=moveit_setup_assistant __log:=/home/linux/.ros/log/cd4f6daa-6115-11e9-9392-b8ca3aa30f44/moveit_setup_assistant-2.log].
log file: /home/linux/.ros/log/cd4f6daa-6115-11e9-9392-b8ca3aa30f44/moveit_setup_assistant-2*.log
Initiating shutdown!
================================================================================
[moveit_setup_assistant-2] killing on exit
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

Do you have any idea? What can cause it? What else can I check? I am trying to understand the MoveIt!, so far without much success. So I will be glad for any explanations. Thank you.

MoveIt setup assistant crashes during collision matrix building

I am trying to use MoveIt! with a custom robot. I have buit a simple one arm robot that can rotate around 2 axes.

I have installed the MoveIt!, built the robot and now I want to generate the moveit files using the MoveIt setup assistant. When I load the model description into the assistant, the whore whole robot is red.

image description

When I click the Create Collision Matrix button in the Self-Collisions tab, the assistant crashes. Closes itself and prints on the terminal only, that the process has died. The terminal outputs speaks about a log, but this log was not created. So I don't even know what error I got.

image description

the full terminal output:

linux@linux-Precision-T1650:~/catkin_ws/src$ roslaunch moveit_setup_assistant setup_assistant.launch
... logging to /home/linux/.ros/log/cd4f6daa-6115-11e9-9392-b8ca3aa30f44/roslaunch-linux-Precision-T1650-29494.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://linux-Precision-T1650:41067/

SUMMARY
========

PARAMETERS
 * /rosdistro: kinetic
 * /rosversion: 1.12.14

NODES
  /
    moveit_setup_assistant (moveit_setup_assistant/moveit_setup_assistant)

auto-starting new master
process[master]: started with pid [29508]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to cd4f6daa-6115-11e9-9392-b8ca3aa30f44
process[rosout-1]: started with pid [29522]
started core service [/rosout]
process[moveit_setup_assistant-2]: started with pid [29534]
[rospack] Error: no package given
[librospack]: error while executing command
xacro: Traditional processing is deprecated. Switch to --inorder processing!
To check for compatibility of your document, use option --check-order.
For more infos, see http://wiki.ros.org/xacro#Processing_Order
[ INFO] [1555508218.850993372]: Loaded robotic_arm robot model.
[ INFO] [1555508218.851097573]: Setting Param Server with Robot Description
[ INFO] [1555508218.860170230]: Robot semantic model successfully loaded.
[ INFO] [1555508218.860221031]: Setting Param Server with Robot Semantic Description
[ INFO] [1555508218.894222163]: Loading robot model 'robotic_arm'...
[ INFO] [1555508218.894272202]: No root/virtual joint specified in SRDF. Assuming fixed joint
[ INFO] [1555508219.506530968]: Stereo is NOT SUPPORTED
[ INFO] [1555508219.506640640]: OpenGl version: 4.6 (GLSL 4.6).
[ INFO] [1555508219.734681131]: Loading robot model 'robotic_arm'...
[ INFO] [1555508219.734724579]: No root/virtual joint specified in SRDF. Assuming fixed joint
[ INFO] [1555508219.890169560]: Loading Setup Assistant Complete
================================================================================REQUIRED process [moveit_setup_assistant-2] has died!
process has died [pid 29534, exit code -11, cmd /home/linux/catkin_ws/devel/lib/moveit_setup_assistant/moveit_setup_assistant __name:=moveit_setup_assistant __log:=/home/linux/.ros/log/cd4f6daa-6115-11e9-9392-b8ca3aa30f44/moveit_setup_assistant-2.log].
log file: /home/linux/.ros/log/cd4f6daa-6115-11e9-9392-b8ca3aa30f44/moveit_setup_assistant-2*.log
Initiating shutdown!
================================================================================
[moveit_setup_assistant-2] killing on exit
[rosout-1] killing on exit
[master] killing on exit
shutting down processing monitor...
... shutting down processing monitor complete
done

Do you have any idea? What can cause it? What else can I check? I am trying to understand the MoveIt!, so far without much success. So I will be glad for any explanations. Thank you.