Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Gazebo crashes when selecting robot model

I am trying to create a robot to simulate ros code in Gazebo, but whenever I load it into gazebo and click on it, Gazebo crashes. After viewing rqt_graph, I can see that only the gui crashes. I commented out most of my robot so all that remains is a box, so I don't think it's the model. The gui also doesn't produce a log. I've tried this on another machine and the same thing happens. I am running gazebo 9 installed with ros melodic using an Ubuntu Virtualbox. I am launching gazebo with a launch file.

image description

Gazebo crashes when selecting robot model

I am trying to create a robot to simulate ros code in Gazebo, but whenever I load it into gazebo and click on it, Gazebo crashes. After viewing rqt_graph, I can see that only the gui crashes. I commented out most of my robot so all that remains is a box, so I don't think it's the model. The gui also doesn't produce a log. I've tried this on another machine and the same thing happens. I am running gazebo 9 installed with ros melodic using an Ubuntu Virtualbox. I am launching gazebo with a launch file.

image description

UPDATE:

I have reduced the model down to the chassis. This is the model if it helps.image description

Gazebo crashes when selecting robot model

I am trying to create a robot to simulate ros code in Gazebo, but whenever I load it into gazebo and click on it, Gazebo crashes. After viewing rqt_graph, I can see that only the gui crashes. I commented out most of my robot so all that remains is a box, so I don't think it's the model. The gui also doesn't produce a log. I've tried this on another machine and the same thing happens. I am running gazebo 9 installed with ros melodic using an Ubuntu Virtualbox. I am launching gazebo with a launch file.

image description

UPDATE:

I have reduced the model down to the chassis. This is the model if it helps.

image description