Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Gazebo 11 under WSL (Windows Subsystem for Linux)

Hi there, I've tried to install Gazebo 11 under WSL in Windows 10 build 1903.

Here it is the current status of my installation:

  • the official PPA was added inside /etc/apt/sources.list.d/
  • Gazebo 11 package (gazebo11) and all its dependencies were installed from APT
  • the environment variable DISPLAY was exported from bashrc, with value localhost:0.0 (also :0 was tried)
  • XMing graphical server (version 6.9.0.31) was installed on Windows
  • the mesa-utils package was installed from APT

When I run Gazebo from the command line using gazebo, the following error appears:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  20
  Current serial number in output stream:  20
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  20
  Current serial number in output stream:  20

(in fact it appears twice).

Afterwards, the output stops, but the command does not return; also, no window appears.

Please, can you help me? At least how can I investigate this issue? I have no clue.

Gazebo 11 under WSL (Windows Subsystem for Linux)

Hi there, I've tried to install Gazebo 11 under WSL in Windows 10 build 1903.

Here it is the current status of my installation:

  • the official PPA was added inside /etc/apt/sources.list.d/
  • Gazebo 11 package (gazebo11) and all its dependencies were installed from APT
  • the environment variable DISPLAY was exported from bashrc, with value localhost:0.0 (also :0 was tried)
  • XMing graphical server (version 6.9.0.31) was installed on Windows
  • the mesa-utils package was installed from APT

When I run Gazebo from the command line using gazebo, the following error appears:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  20
  Current serial number in output stream:  20
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  20
  Current serial number in output stream:  20

(in fact it appears twice).

Afterwards, the output stops, but the command does not return; also, no window appears.

Please, can you help me? At least how can I investigate this issue? I have no clue.

Gazebo 11 under WSL (Windows Subsystem for Linux)Linux) [works!]

Hi there, I've tried to install Gazebo 11 under WSL in Windows 10 build 1903.

Here it is the current status of my installation:

  • the official PPA was added inside /etc/apt/sources.list.d/
  • Gazebo 11 package (gazebo11) and all its dependencies were installed from APT
  • the environment variable DISPLAY was exported from bashrc, with value localhost:0.0 (also :0 was tried)
  • XMing graphical server (version 6.9.0.31) was installed on Windows
  • the mesa-utils package was installed from APT

When I run Gazebo from the command line using gazebo, the following error appears:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  20
  Current serial number in output stream:  20
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  143 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  20
  Current serial number in output stream:  20

(in fact it appears twice).

Afterwards, the output stops, but the command does not return; also, no window appears.

Please, can you help me? At least how can I investigate this issue? I have no clue.