Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Robot model destabilizes after some time

Hello all,

I am using the Unmanned Underwater Vehicle Simulator extensively currently and have noticed that some time after uploading and spawning in AUV robot models in Gazebo, they seem to lose stability within a minute or two. First screenshot is the AUV as spawned, and the second is the AUV destabilizing (basically pitching forward and spiking).

image description

image description

To run this, I roslaunch "auv_underwater_world.launch" from the uuv_gazebo_worlds package in the UUVSim suite, and then roslaunch "upload_eca_a9.launch" from the eca_a9_description package, part of the eca_a9 repo from UUVSim.

I have replicated this instability with another custom AUV model, but found that spawning in a simple cylinder with UUVSim's hydrodynamic plugin applied (just as it is in the eca_a9 model) leads to a rock solid, completely stable model. In addition, I have observed the other AUV model in UUVSim, the LAUV, and it is also completely stable and does not pitch forward eventually as this model does - at least not in the 5~7 minutes that I watched.

I have also noticed with the eca_a9's runs that the destabilization seems to start at the same depth every time (-10 meters), but how it destabilizes is different between the two worlds that I tested (auv_underwater_world and ocean_waves).

I am wondering if this destabilization is being caused by numerical error accumulation inherent to the physics solving in Gazebo (kind of like with the RRBot in the Gazebo tutorials, and how it will fall down after a few seconds from being spawned), or if there is some other issue. It is hard to tell due to some models suffering this issue yet others being fine.

Thanks~