Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Sending dynamic pose over the ignition ros bridge.

Hello

When I try to send the dynamic pose topic, in my case "/world/diff_drive/dynamic_pose/info", over the ignition ros bridge I can't seem to get anything when I try to echo the ROS topic. After a little while the terminal prints out "WARNING: no messages received and simulated time is active. Is /clock being published?" I already send the clock over the bridge which I can read when I echo it. When I ros info the topic gives me "Publishers: * /ros_ign_bridge_asger_37872_7829015288749452839 (http://asger:46361/)" which seems fine.

This is my arguements for the bridge: args="/clock@rosgraph_msgs/Clock[ignition.msgs.Clock /world/diff_drive/dynamic_pose/info@geometry_msgs/Pose[ignition.msgs.Pose"> Hope you can help me.

Best regards, Asger Printz Madsen, Robotics 9 | Aalborg University

Sending dynamic pose over the ignition ros bridge.

Hello

When I try to send the dynamic pose topic, in my case "/world/diff_drive/dynamic_pose/info", "/world/diff_drive/dynamic_pose/info", over the ignition ros bridge I can't seem to get anything when I try to echo the ROS topic. After a little while the terminal prints out "WARNING: no messages received and simulated time is active. Is /clock being published?" I already send the clock over the bridge which I can read when I echo it. When I ros info the topic gives me "Publishers: "Publishers: * /ros_ign_bridge_asger_37872_7829015288749452839 (http://asger:46361/)" (http://asger:46361/)" which seems fine.

This is my arguements for the bridge: args="/clock@rosgraph_msgs/Clock[ignition.msgs.Clock /world/diff_drive/dynamic_pose/info@geometry_msgs/Pose[ignition.msgs.Pose"> /world/diff_drive/dynamic_pose/info@geometry_msgs/Pose[ignition.msgs.Pose">

Hope you can help me.

Best regards, Asger Printz Madsen, Robotics 9 | Aalborg University