Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

Gazebo MAC OSX 11 1 does not install

Hi, I get the following error when running make px4_sitl gazebo ninja: error: '/Library/Developer/CommandLineTools/SDKs/MacOSX11.0.sdk/usr/lib/libm.tbd', needed by 'libmav_msgs.dylib', missing and no known rule to make it

This is true because the SDK folder has; MacOSX.sdk MacOSX10.15.sdk MacOSX11.1.sdk

I also see that within SDKs/MacOSX11.0.sdk/usr/lib/ there is no libm.tbd file..

How to solve this?

Cheers!