Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Problems to spawn an URDF model with gazebo_ros

Hi there!

I'm working with a custom robot here. We are moving into ROS for controlling and interfacing with many sensors and use moveIt! as trajectory planner. So we are completely newbies here.

I had made the urdf file, which seems to work OK for rviz or movitIt wizard configuration. But despite following the tutorials from wiki the simulator wont come up with the robot.

I'm using ubuntu 12.04 with groovy. Gazebo and gazebo_ros are installed from source and seems to work loading and empty world.

What I tried to execute is the next command, where 'myrobot' is actually the robot name.

rosrun gazebo_ros  spawn_model -file 'rospack find myrobot_description'/urdf/myrobot.urdf -urdf -model myrobot

The comand line output spites:

spawn_model script started
[INFO] [WallTime: 1372951949.703358] Loading model xml from file
[INFO] [WallTime: 1372951949.703925] Waiting for service /gazebo/spawn_urdf_model

And stays there forever. When hit ctrl+c appears that trace back:

Traceback (most recent call last):
File "/home/ros/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/scripts/spawn_model", 
line 292, in <module>sm.callSpawnService()
File "/home/ros/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/scripts/spawn_model", 
line 258, in callSpawnService initial_pose, self.reference_frame, self.gazebo_namespace)
File "/home/ros/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/src/gazebo_ros/", 
line 27, in spawn_urdf_model_client rospy.wait_for_service(gazebo_namespace+'/spawn_urdf_model')
File "/opt/ros/groovy/lib/python2.7/dist-packages/rospy/impl/", line 162,
in wait_for_service raise ROSInterruptException("rospy shutdown")
rospy.exceptions.ROSInterruptException: rospy shutdown

I even tried with the tutorial for Baxter, but seems there is no URDF in the repository where it is supposed you will get it.

Any hint on how go on. I could not execute moveIt until gazebo works it seems, and after sorting all the configuration and installation troubles, here I get stuck with no clue on how keep going. So all your help will be specially appreciated!

Thanks in advance, and thanks for this great tools.