Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

gazebo crashes immediately using roslaunch after installing gazebo ros packages

Hello,

after installing everything properly I am following the tutorials to test the tools (using groovy, gazebo 1.9 and gazebo_ros_pkgs). I have a problem using roslaunch to start gazebo following this tutorial

http://gazebosim.org/wiki/Tutorials/1.9/Using_roslaunch_Files_to_Spawn_Models

when I want to start with command roslaunch gazebo_ros willowgarage_world.launch gazebo crashes after one sec and I get this error:

[gazebo_gui-3] process has died [pid 15649, exit code 139, cmd /home/usr/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/scripts/gzclient __name:=gazebo_gui __log:=/home/shahed/.ros/log/8981441a-03ea-11e3-8d2b-0017c4a8146b/gazebo_gui-3.log]. log file: /home/usr/.ros/log/8981441a-03ea-11e3-8d2b-0017c4a8146b/gazebo_gui-3*.log

this problem happens with all world files( mud_world.launch, shapes_world.launch, rubble_world.launch), except the empty and willowgarage_world, both of them can be started using roslaunch tool but not always from the first attempt. Mostly from the second try.

I also followed “Creating a Custom World File” in the same tutorial and still the same problem occurred.

Any help plz!

Thanks in advance.

gazebo crashes immediately using roslaunch after installing gazebo ros packages

Hello,

after installing everything properly I am following the tutorials to test the tools (using groovy, gazebo 1.9 and gazebo_ros_pkgs). I have a problem using roslaunch to start gazebo following this tutorial

http://gazebosim.org/wiki/Tutorials/1.9/Using_roslaunch_Files_to_Spawn_Models

when I want to start with command roslaunch gazebo_ros willowgarage_world.launch gazebo crashes after one sec and I get this error:

[gazebo_gui-3] process has died [pid 15649, exit code 139, cmd /home/usr/catkin_ws/src/gazebo_ros_pkgs/gazebo_ros/scripts/gzclient __name:=gazebo_gui __log:=/home/shahed/.ros/log/8981441a-03ea-11e3-8d2b-0017c4a8146b/gazebo_gui-3.log].
log file: /home/usr/.ros/log/8981441a-03ea-11e3-8d2b-0017c4a8146b/gazebo_gui-3*.log

/home/usr/.ros/log/8981441a-03ea-11e3-8d2b-0017c4a8146b/gazebo_gui-3*.log

this problem happens with all world files( mud_world.launch, shapes_world.launch, rubble_world.launch), except the empty and willowgarage_world, both of them can be started using roslaunch tool but not always from the first attempt. Mostly from the second try.

I also followed “Creating a Custom World File” in the same tutorial and still the same problem occurred.

Any help plz!

Thanks in advance.