Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Gazebo 1.5 ros::InvalidNameException

I have tried several combination of ROS and gazebo but unfortunatly there is still a problem somewhere in each version. I have ROS fuerte, groovy and Hydro on one system which I can switch through by sourcing different setup files.

If I run roslaunch gazebo_worlds empty_world_sdf.launch:

Gazebo multi-robot simulator, version 1.5.0
Copyright (C) 2013 Open Source Robotics Foundation.
Released under the Apache 2 License.

terminate called after throwing an instance of 'ros::InvalidNameException'
  what():  Character [] at element [8] is not valid in Graph Resource Name [gazeboeb].  Valid characters are a-z, A-Z, 0-9, / and _.
Msg Waiting for master
Error [] Connection[0] Closed during Read
Aborted (core dumped)
terminate called after throwing an instance of 'boost::system::system_error'
  what():  Connection reset by peer
Aborted (core dumped)
[gazebo-2] process has died [pid 3263, exit code 134, cmd /opt/ros/groovy/stacks/simulator_gazebo/gazebo/scripts/gazebo /opt/ros/groovy/stacks/simulator_gazebo/gazebo_worlds/worlds/ __name:=gazebo __log:=/home/lennart/.ros/log/b3574644-2501-11e3-93d9-00216a4e286a/gazebo-2.log].
log file: /home/lennart/.ros/log/b3574644-2501-11e3-93d9-00216a4e286a/gazebo-2*.log
[gazebo_gui-3] process has died [pid 3272, exit code 134, cmd /opt/ros/groovy/stacks/simulator_gazebo/gazebo/scripts/gui __name:=gazebo_gui __log:=/home/lennart/.ros/log/b3574644-2501-11e3-93d9-00216a4e286a/gazebo_gui-3.log].
log file: /home/lennart/.ros/log/b3574644-2501-11e3-93d9-00216a4e286a/gazebo_gui-3*.log

How can I debug this? There seem to be no variables set, echo $GAZEBO is empty. Should I source a file? If I try to source

 source /opt/ros/groovy/stacks/simulator_gazebo/gazebo/setup.bash
[rospack] Error: stack/package ogre not found

When the resource path is changed than this works. Paths:



Are these correct?

(I did ask this question before: