Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hokuyo not pubishing to ROS


I would like to publish laser scans, that are performed by e.g the Hokuyo Model in Gazebo to ROS. I have tried this with Fuerte and Hydro without success.

I used this materials: Gazebo 1.9 ROS Hydro Ubuntu 12.04

I then started Gazebo with this command

roslaunch gazebo_ros empty_world.launch

This then gives me these topics in ROS

rostopic list

In Gazebo I added the Hokuyo model which is already included. I can see the scanarea indicated in blue. I can'T see any new topic in ROS. I can see in the model.sdf that it uses the Plugin. Furthermore I noticed that a topic tag is missing inside the sensor tag. I added one. Still no publishing.Thas how the sensor section model.sdf of the Hokuyo looks like

  <sensor name="laser" type="ray">
        <pose>0.01 0 0.0175 0 -0 0</pose>

        <plugin name="laser" filename="" />

I tried different topics such as /laser_scan, laser_scan. Am I missing something?

BR & and thanks for any help