Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Gazebo crashes when spawning a robot with urdf.

Hello,

I'm looking forward to use ROS Indigo with the fresh released Ubuntu 14.04. Gazebo is starting fine but instantly crashes when spawning a robot via service call:

(indigo) alex@ThinkPad-T440p:~/hector$ rosrun gazebo_ros spawn_model -file `rospack find baxter_description`/urdf/baxter.urdf -urdf -z 1 -model baxter
spawn_model script started
[INFO] [WallTime: 1400760484.921875] [0.000000] Loading model xml from file
[INFO] [WallTime: 1400760484.922486] [0.000000] Waiting for service /gazebo/spawn_urdf_model
[INFO] [WallTime: 1400760484.924802] [0.000000] Calling service /gazebo/spawn_urdf_model
Service call failed: transport error completing service call: unable to receive data from sender, check sender's logs for details

Lets Gazebo crash without any message:

[gazebo-1] process has died [pid 14649, exit code 139, cmd /opt/ros/indigo/lib/gazebo_ros/gzserver worlds/empty.world __name:=gazebo __log:=/home/alex/.ros/log/cdde1b80-e1a0-11e3-ab05-5c514ff707c4/gazebo-1.log].
log file: /home/alex/.ros/log/cdde1b80-e1a0-11e3-ab05-5c514ff707c4/gazebo-1*.log

I've just tested it with Gazebo 2.2.2 (sudo apt-get install ros-indigo-gazebo-ros) using "empty_world" and the Baxter robot urdf (see gazebosim.org /Tutorials/1.9/Using_roslaunch_Files_to_Spawn_Models, sry not enough Karma for links ;)).

Has anybody encountered this issue too?

kind regards, Alex

Gazebo crashes when spawning a robot with urdf.

Hello,

I#ve already asked in ros answer but didn't received any answer (http://answers.ros.org/question/168156/gazebo-crashes-when-spawning-a-robot-with-urdf/). Thus, I try it here again.

I'm looking forward to use ROS Indigo with the fresh released Ubuntu 14.04. Gazebo is starting fine but instantly crashes when spawning a robot via service call:

(indigo) alex@ThinkPad-T440p:~/hector$ rosrun gazebo_ros spawn_model -file `rospack find baxter_description`/urdf/baxter.urdf -urdf -z 1 -model baxter
spawn_model script started
[INFO] [WallTime: 1400760484.921875] [0.000000] Loading model xml from file
[INFO] [WallTime: 1400760484.922486] [0.000000] Waiting for service /gazebo/spawn_urdf_model
[INFO] [WallTime: 1400760484.924802] [0.000000] Calling service /gazebo/spawn_urdf_model
Service call failed: transport error completing service call: unable to receive data from sender, check sender's logs for details

Lets Gazebo crash without any message:

[gazebo-1] process has died [pid 14649, exit code 139, cmd /opt/ros/indigo/lib/gazebo_ros/gzserver worlds/empty.world __name:=gazebo __log:=/home/alex/.ros/log/cdde1b80-e1a0-11e3-ab05-5c514ff707c4/gazebo-1.log].
log file: /home/alex/.ros/log/cdde1b80-e1a0-11e3-ab05-5c514ff707c4/gazebo-1*.log

I've just tested it with Gazebo 2.2.2 (sudo apt-get install ros-indigo-gazebo-ros) using "empty_world" and the Baxter robot urdf (see gazebosim.org /Tutorials/1.9/Using_roslaunch_Files_to_Spawn_Models, sry not enough Karma for links ;)).

Has anybody encountered this issue too?

kind regards, Alex

Gazebo crashes when spawning a robot with urdf.

Hello,

I#ve I've already asked in ros answer but didn't received any answer (http://answers.ros.org/question/168156/gazebo-crashes-when-spawning-a-robot-with-urdf/). Thus, I try it here again.

I'm looking forward to use ROS Indigo with the fresh released Ubuntu 14.04. Gazebo is starting fine but instantly crashes when spawning a robot via service call:

(indigo) alex@ThinkPad-T440p:~/hector$ rosrun gazebo_ros spawn_model -file `rospack find baxter_description`/urdf/baxter.urdf -urdf -z 1 -model baxter
spawn_model script started
[INFO] [WallTime: 1400760484.921875] [0.000000] Loading model xml from file
[INFO] [WallTime: 1400760484.922486] [0.000000] Waiting for service /gazebo/spawn_urdf_model
[INFO] [WallTime: 1400760484.924802] [0.000000] Calling service /gazebo/spawn_urdf_model
Service call failed: transport error completing service call: unable to receive data from sender, check sender's logs for details

Lets Gazebo crash without any message:

[gazebo-1] process has died [pid 14649, exit code 139, cmd /opt/ros/indigo/lib/gazebo_ros/gzserver worlds/empty.world __name:=gazebo __log:=/home/alex/.ros/log/cdde1b80-e1a0-11e3-ab05-5c514ff707c4/gazebo-1.log].
log file: /home/alex/.ros/log/cdde1b80-e1a0-11e3-ab05-5c514ff707c4/gazebo-1*.log

I've just tested it with Gazebo 2.2.2 (sudo apt-get install ros-indigo-gazebo-ros) using "empty_world" and the Baxter robot urdf (see gazebosim.org /Tutorials/1.9/Using_roslaunch_Files_to_Spawn_Models, sry not enough Karma for links ;)).

Has anybody encountered this issue too?

kind regards, Alex