Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

Problems with Install to Gazebo 3

Hello Everyone!!

I have problems when try to install Gazebo3 for Ubuntu 12.04

http://gazebosim.org/wiki/3.0/install

I used:

sudo sh -c 'echo "deb http://packages.osrfoundation.org/gazebo/ubuntu precise main" > /etc/apt/sources.list.d/gazebo-latest.list'
wget http://packages.osrfoundation.org/gazebo.key -O - | sudo apt-key add -
sudo apt-get update
sudo apt-get install gazebo3

Error:

Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
gazebo3 ya está en su versión más reciente.
Tal vez quiera ejecutar «apt-get -f install» para corregirlo:
Los siguientes paquetes tienen dependencias incumplidas:
gazebo3 : Depende: libsdformat2 pero no va a instalarse
gazebo3-plugin-base : Depende: libsdformat2 pero no va a instalarse
libgazebo-dev : Depende: libprotoc-dev pero no va a instalarse
             Depende: libprotobuf-dev pero no va a instalarse
             Depende: libogre-dev pero no va a instalarse
             Depende: libtar-dev pero no va a instalarse
             Depende: libcegui-mk2-dev pero no va a instalarse
             Depende: libgts-dev pero no va a instalarse
             Depende: libsdformat2-dev pero no va a instalarse
 libgazebo3 : Depende: libcegui-mk2-0.7.5 pero no va a instalarse
          Depende: libogre-1.7.4 pero no va a instalarse
          Depende: libplayercommon3.0 pero no va a instalarse
          Depende: libplayercore3.0 pero no va a instalarse
          Depende: libplayerinterface3.0 pero no va a instalarse
          Depende: libsdformat2 pero no va a instalarse
          Depende: libtar0 pero no va a instalarse
 libplayerc++3.0 : Depende: libplayerinterface3.0 pero no va a instalarse
 libplayerc3.0 : Depende: libplayerinterface3.0 pero no va a instalarse
 libplayercommon3.0-dev : Depende: libplayercommon3.0 (= 3.0.2+dfsg-3ubuntu2) pero no va a instalarse
 libplayercore3.0-dev : Depende: libplayercore3.0 (= 3.0.2+dfsg-3ubuntu2) pero no va a instalarse
 libplayerdrivers3.0 : Depende: libplayercommon3.0 pero no va a instalarse
                   Depende: libplayercore3.0 pero no va a instalarse
                   Depende: libplayerinterface3.0 pero no va a instalarse
 libplayerinterface3.0-dev : Depende: libplayerinterface3.0 (= 3.0.2+dfsg-3ubuntu2) pero no va a instalarse
 libplayertcp3.0 : Depende: libplayercommon3.0 pero no va a instalarse
               Depende: libplayercore3.0 pero no va a instalarse
               Depende: libplayerinterface3.0 pero no va a instalarse
 libplayerwkb3.0 : Depende: libplayercommon3.0 pero no va a instalarse
 ros-hydro-class-loader : Depende: libpocofoundation9 pero no va a instalarse
                      Depende: libpoco-dev pero no va a instalarse
 ros-hydro-gazebo3-plugins : Depende: libogre-1.7.4 pero no va a instalarse
                         Depende: libsdformat2 pero no va a instalarse
 ros-hydro-gazebo3-ros : Depende: libsdformat2 pero no va a instalarse
 ros-hydro-rosgraph : Depende: python-netifaces pero no va a instalarse
 ros-hydro-roslisp : Depende: sbcl pero no va a instalarse
 E: Dependencias incumplidas. Intente «apt-get -f install» sin paquetes (o especifique una solución).

And when try to use in the Terminal $ gazebo, get this error:

gazebo: error while loading shared libraries: libsdformat.so.2: cannot open shared object file: No such file or directory

A lot of thanks