Gazebo | Ignition | Community
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Invalid tag: Cannot load Husky into gazebo

Hello, I am currently running the Husky packages on gazebo-4.0. It worked fine till yesterday, but when I run it again using roslaunch it shows following error

 rahul@rahul-pc:~/husky_ws$ roslaunch husky_gazebo husky_empty_world.launch 
... logging to /home/rahul/.ros/log/014e7106-9478-11e4-b211-a4db30d7dfe6/roslaunch-rahul-pc-4352.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

Traceback (most recent call last):
  File "/opt/ros/indigo/share/xacro/", line 60, in <module>
AttributeError: 'module' object has no attribute 'main'
while processing /home/rahul/sample_ws/src/husky_gazebo/launch/base.urdf.gazebo.launch:
Invalid <param> tag: Cannot load command parameter [robot_description]: command [/opt/ros/indigo/share/xacro/        '/home/rahul/sample_ws/src/husky_description/urdf/base.urdf.xacro'          gps_enabled:=true         imu_enabled:=true  front_laser:=true     ] returned with code [1]. 

Param xml is <param command="$(find xacro)/        '$(find husky_description)/urdf/base.urdf.xacro'          gps_enabled:=$(arg gps_enabled)         imu_enabled:=$(arg imu_enabled)  front_laser:=$(arg front_laser)     " name="robot_description"/>
The traceback for the exception was written to the log file

I don't know how to solve this problem. A little help would be appreciated. Thank you for your useful time